Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have several Mac users attached to my NAS whose usernames exceed the 16 char user display (ie SportsFreelancer01), so under the ls -al command, it shows up as user "SportsFreelancer", without #. Is there a way to set the default display to more than 16? Say 24 or 36 (or any)?

Thanks

share|improve this question

1 Answer 1

If you have multiple names that are the same (SportsFreelancer01, SportsFreelancer02, etc.) You could use the -n option, which would display numbers instead of names.

If you really want the names, try setting LS_COLWIDTHS to 0:0:0:0:0:0:0:0. The 4th 0 is the user name; you might try a 64 or 32 in there.

share|improve this answer
    
Is this in a pref somewhere? can I set it for all sessions, or is it session specific? –  Tom Mar 13 '12 at 18:22
    
you could put it in your .bashrc. Test first though by just setting on the command line i.e. export LS_COLWIDTHS="0:0:0:0:0:0:0:0" –  Scott Wilson Mar 13 '12 at 18:25
    
looks like my Mac OS X 10.6.8 has dynamic display on by default. My affected system is an Isilon running OneFS...root runs zsh. Running export does not change display (command executes tho) –  Tom Mar 13 '12 at 20:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.