Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to remotely debug a problem with my Dad's office email:

They're connected to a Belkin N1 router using PPPoE provided by (a SOHO account I think). Using Outlook 2003 on Windows XP. Mail is download via POP and set to send via SMTP using

Issue: Every 2-3 days the email refuses to send for no apparent reason.

I've tried Outlook logging but haven't yet been able to catch it in the act.

Actions taken so far:

  • firmware update on router
  • DNS altered to specify Claranet as primary DNS and Google public as secondary
  • Set static internal IPs
  • Checked access settings and confirmed them to be working
  • Enabled TLS, tried alternate port (587 instead of 25)
  • Checked access via command line local to them and local to me; always seems to send and receive when I'm looking!

It's possible that there is a general internet slowdown but that's just assuming.

There are 2 wired and 2 wireless connections at most. SMTP fails randomly irrespective of the number of clients attempting to send.

Rebooting the router almost always allows an email to be sent but the reports are that at the worst this must be repeated each time an email is sent. ISP does give dynamic IPs.

Any suggestions for next line of attack?

share|improve this question
Without logs it's hard to tell something. Did you tried to speak with Clara's support? Are any signs of repeatability in message size? I worked with something-like-this problem long time ago and source of troubles was different MTU-size (lesser than usual) on route and "DF" flag – Lazy Badger Mar 13 '12 at 18:55
Next (easy) line - change client and use MUA with good sessions-logging – Lazy Badger Mar 13 '12 at 18:56
My first action was to use Thunderbird to automatically discover the available server settings. Sending and receiving work fine with TB too ... just trying to get that elusive window when the system is fubar-ed so I can test and narrow down the source of the problem. As for DF flag and MTU, how did you/would I address these. I can see how one could trace them potentially but how could I set such fine tuning on outgoing Outlook emails? No idea about that. Thanks for the suggestions. – pbhj Mar 13 '12 at 18:59
I sent small text only mails with small steps to go - I know, how much data added by my MTA and I could calculate final size – Lazy Badger Mar 13 '12 at 19:12
Using tcpview (from sysinternals) I saw that a SYN being sent by Outlook but no ACK. So then I ran a remote mtr to the SMTP server that showed no problems; then I ran a winmtr trace locally and found that there was a "blockage". That's when I noticed the addresses were different and that in fact instead of 80.x.y.10 the address being used was 10.y.x.80!! Weird. I've hacked a fix of specifying the server address in the hosts file. Thanks for your suggestions. – pbhj Mar 19 '12 at 14:06

This can happen in times pans of minutes, hours or days. The only fix I have found is to rerun the Network Setup Wizard or New Connection Wizard in Network Connections choosing the residential gateway. Somehow this resets everything and is a pretty permanent solution.

You might want to go to Device Manager first and click on the Network Adapters section and then right click to Scan for hardware changes. This somehow helps the Network Setup above.

Sometimes after you finish you will see a new "Internet Gateway" connection and sometimes not. If you see the Internet Gateway Connection it seems to fix the problem. Sometimes it is fixed without that showing. I found I have to repeat the above steps until the Internet Gateway shows up as it is hit or miss and I have no idea why. The Internet Gateway will disappear from the Network Connections at some point but you won't have the disconnect issues anymore.

It took a lot of trial and error to figure this out but it does work (at least for me) and I have no idea why. It's worth a try. I have searched all over and have found nothing else that works.

Hope this helps.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.