Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Today I installed Linux Debian in dual boot with Windows 7. I have 3 hard drives, two for starage and one for the operating systems. The problem is with the two storage drives which are exactly same. In debian I can only see one of them.

Before Debian I had Ubuntu and there wasn't any problem. Also I didn't changed anything from that drive.

What should I do? I don't want to format it or delete anything.

share|improve this question

migrated from Mar 13 '12 at 17:44

This question came from our site for professional and enthusiast programmers.

1 – Bry6n Mar 13 '12 at 16:27
What do you get from sudo fdisk -l – Rob Mar 15 '12 at 18:56
here 's my output The problem is with the last drive /dev/sdd1 – nask00s Mar 16 '12 at 15:37
By exactly the same, do you mean model or do you mean you've cloned one harddrive so it's the same as the other? – Rob Mar 20 '12 at 19:00

What do you mean it cant see them? Have you checked the output of dmesg to see what device names theyve been assigned? Have you tried something like cfdisk /dev/sda then /dev/sdb and /dev/sdc as root?

Linux should see all harddrives by default, unless they be RAID or some other strange hardware configuration, if they are IDE/PATA or SATA they must be "visible". Do you have strange hardware to your disks?

share|improve this answer
Sorry for my English but its not my native language. The is SATA and it's not in RAID. I tried cfdisk /dev/sdd bad it prints Fatal Error: Bad primary partition 0 ... – nask00s Mar 13 '12 at 17:11

This seems like it might be a case of a corrupted hard drive, or a corrupted partition table. One extremely rough check is to run "badblock" on /dev/sdd and see what kind of output you get (this may take a while). If it reports a lot of errors, or an error in the early blocks, that means that the disk is damaged.

If not, can you afford to lose the data on the drive that cannot be detected / read? In that case, I would use a tool like gparted, or fdisk if you are familiar enough with it, to write a new partition table to the drive. I believe gparted is somewhat safer, but fdisk can also do this with a few commands. Check man fdisk or google gparted for more information. You will have to install gparted on most debian systems (it does not generally come with the basic installs).

share|improve this answer
It can't be corrupted as I mentioned on my post I have dual boot debian and windows7, with windows there is no problem with this hard drive. – nask00s Mar 20 '12 at 18:15
Did you format this drive in Windows? If so, what options did you choose? – ShankarG Mar 21 '12 at 3:45
I didn't format since I bought it, because there I store big amounts of essential files. – nask00s Mar 21 '12 at 13:47
Perhaps it is formatted in an odd way. Most likely it's an NTFS drive if you never formatted it, but it may be compressed or something. Can you post the output of "sudo blkid /dev/sdd"? Also, try installing gparted and seeing what it says about this drive - its error messages more informative. Finally, if you are not able to figure out anything meaningful, try posting to the debian users mailing list - you may get help there. – ShankarG Mar 22 '12 at 4:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .