Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

A program is trying to send an e-mail message on your behalf. If this is unexpected, click Deny and verify your antivirus software is up-to-date.

When doing an email merge from Excel data, via a Word template, into Outlook (all Office 2010), I get the dialog displayed above. For every single email, I have to wait 5 seconds, then click the Allow button.

I'm not even using any scripting or VBA; this is just a straight email merge from Word. I find it confusing that there appears to be no easy way to disable this dialog. All the tips and fixes I can find for this involve fixing the issue for VBA or for an external program, not for Office applications internally. In fact, the directions (from Microsoft) for doing email merges don't even mention this dialog at all. The last step at the bottom of that page is what I did just before two dialogs appeared; one that had me 'grant access' for 10 minutes to another program, and then this dialog over and over.

Any suggestion?

share|improve this question
add comment

1 Answer

Start Outlook as an administrator (you may have to press CTRL+Shift to make this option appear when right clicking on the Outlook Shortcut). Then click the File tab, select Options > Trust Center > Trust Center Settings > Programmatic Access. Click Never Warn me about suspicious activity. This will solve the problem. I would recommend turning the warning back on after the mail merge, unless you do a lot of them.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.