Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Ubuntu 11.10 64bit, 3.0.0-16 kernel on Dell XPS L502x has strange problem with integrated Intel Wireless card (Intel(R) Centrino(R) Wireless-N 1030 BGN, REV=0xB0) or iwlagn drivers. After suspend and resume network does not work on some routers. It works with old Fonera (serving b/g) but not with TP-Link TL-MR3420 (serving b/g/n or only b/g). It does not depend on open/WEP/WPA. While integrated wifi was not working I tried alsowith USB Wifi stick. It worked well.

Trying to solve the iwlagn problem:

  • rmmod / modprobe does not help
  • reboot does not help
  • syslog displays that I get IP address but then starts displaying errors Aggregation not enabled for tid 0 because load = ... see below; (these errors are not always displayed with this error condition, but never, when wifi works)
  • Only thing that helps is booting to Windows (lucky me - kept the partition), using network, and booting back to Ubuntu.

Syslog

Mar 13 19:40:32 xenops avahi-daemon[1053]: New relevant interface wlan0.IPv4 for mDNS.
Mar 13 19:40:32 xenops avahi-daemon[1053]: Registering new address record for 192.168.1.109 on wlan0.IPv4.
Mar 13 19:40:33 xenops NetworkManager[1046]: <info> (wlan0): device state change: ip config -> activated (reason 'none') [70 100 0]
Mar 13 19:40:33 xenops NetworkManager[1046]: <info> Policy set 'Auto ADOJAANW' (wlan0) as default for IPv4 routing and DNS.
Mar 13 19:40:33 xenops NetworkManager[1046]: <info> Activation (wlan0) successful, device activated.
Mar 13 19:40:33 xenops NetworkManager[1046]: <info> Activation (wlan0) Stage 5 of 5 (IP Configure Commit) complete.
Mar 13 19:40:33 xenops NetworkManager[1046]: <info> Activation (wlan0) Stage 4 of 5 (IP4 Configure Get) complete.
Mar 13 19:40:33 xenops dbus[1016]: [system] Activating service name='org.freedesktop.nm_dispatcher' (using servicehelper)
Mar 13 19:40:33 xenops dbus[1016]: [system] Successfully activated service 'org.freedesktop.nm_dispatcher'
Mar 13 19:40:38 xenops kernel: [135455.414902] iwlagn 0000:03:00.0: Aggregation not enabled for tid 0 because load = 6
Mar 13 19:40:40 xenops kernel: [135457.328053] wlan0: no IPv6 routers present
Mar 13 19:40:48 xenops kernel: [135464.874894] iwlagn 0000:03:00.0: Aggregation not enabled for tid 0 because load = 3
Mar 13 19:40:51 xenops kernel: [135468.396103] iwlagn 0000:03:00.0: iwlagn_tx_agg_start on ra = b0:48:7a:e9:6a:8a tid = 0
Mar 13 19:40:55 xenops kernel: [135472.248823] iwlagn 0000:03:00.0: Aggregation not enabled for tid 0 because load = 5
Mar 13 19:40:59 xenops kernel: [135475.904076] iwlagn 0000:03:00.0: iwlagn_tx_agg_start on ra = b0:48:7a:e9:6a:8a tid = 0
Mar 13 19:41:03 xenops kernel: [135479.908297] iwlagn 0000:03:00.0: iwlagn_tx_agg_start on ra = b0:48:7a:e9:6a:8a tid = 0
share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.