Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I installed 11.10 on my desktop PC but get a black screen after the BIOS screen when I try to boot it. I was able to run 10.04.04 on my hard drive before installing 11.10 and I am also able to use 11.10 on my usb pendrive and CD ROM. I've tried unplugging all USB devices before booting and also upgrading from 11.10 to 11.10. Holding the shift key from the BIOS screen doesn't allow me to access the GRUB menu to try:

Highlight the first entry, press “e” to edit it. Navigate to words “quiet splash”, delete them and type “nomodeset” in their place (without quotes). Press Ctrl + X to continue boot. Once on the desktop, go to System > Administration > Additional Drivers and activate the recommended drivers.

So running 11.10 on my pendrive, I tried editing /etc/default/grub, commenting out the GRUB_HIDDEN_TIMEOUT setting by putting a '#' in front of it to display the grub menu and setting GRUB_TIMEOUT setting to a value greater than or equal to 1 e.g. GRUB_TIMEOUT=10.

However, when I run sudo update-grub, I get:

/usr/sbin/grub-probe: error: cannot find a device for / (is /dev mounted?)

I get the same error with update-grub after:

sudo mount /dev/sda1 /mnt

and after:

sudo grub-install --root-directory=/mnt /dev/sda
reboot
sudo update-grub

Other suggestions to fix the update-grub problem:

Open synaptic, then purge all the related grub installed packages and reinstall grub-pc then and finally: sudo update-grub

Or use Grub Customizer http://ubuntuforums.org/showthread.php?t=1195275

What would be the best way to approach this? I'm concerned about purging "all the related grub installed packages" but if it's true some files are corrupted this would seem necessary. Also, was I executing the correct commands i.e. with mount and grub-install, before running grub-update?

share|improve this question
    
In the first case of the black screen after bios, do you see blinking screens and disk activity? I had seen something similar because the graphics card wasn't supported. What graphics card does the desktop have? –  jdh Mar 14 '12 at 0:46
    
No. The card is supported, it's an AMD Radeon HD 6450. –  izn Mar 14 '12 at 1:18

1 Answer 1

up vote 2 down vote accepted

Running Boot-Info (formerly called Boot-Repair, installation instructions here) solved the problem. In Boot-Info, I chose Advanced options->GRUB options. I selected 'Add a kernel option:" and selected acpi_osi= from the drop down menu beside it to make the kernel not respond to osi queries (as suggested here because some bioses contain fixes for specific Windows versions that may not work with other OS's).

I clicked on 'Edit GRUB configuration file' which loaded /mnt/boot-sav/sda1/etc/default/grub. In this file I set GRUB_CMDLINE_LINUX_DEFAULT="" , removing it's quiet splash value to display the boot messages when booting (splash enables the splash screen with condensed text output and quiet splash results in just the splash screen image being shown), put a # in front of GRUB_HIDDEN_TIMEOUT to display the grub menu and set GRUB_TIMEOUT=10 to give the user 10 seconds to make a selection. I don't recall but these changes may already have been made from my previous attempt to edit the GRUB configuration as described in the question.

More details on Grub2: https://help.ubuntu.com/community/Grub2

You can also adjust the amount of time to 'Unhide boot menu' in the Advanced options->Main options. This was left at the default value of 10 seconds. 'Reinstall GRUB' was also selected by default. In Advanced options->GRUB location, the default settings were 'sda1' for 'OS to boot by default' and 'Place GRUB in all disks (except USB disks without OS)' was selected.

I clicked 'Apply' and restarted the computer after Boot-Info finished running. I changed the boot order of hard drives in the BIOS (my usb pen drive was listed as a hard drive so I would adjust the order according to which drive I wanted to log into) then pressed 'Enter' at the Grub menu. After the boot messages, the login screen appeared. The system also automatically boots after the Grub menu appears for 10 seconds.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.