Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a VAIO CW laptop with Windows 7 x64, and after installing new NVIDIA drivers, my screen brightness controls are no longer available. (Not in the control center, not in the power options, buttons don't work even though VAIO's brightness adjust window pops up, etc.).

My display doesn't dim either.

It works fine on other OSes (e.g. Windows 8).

I've tried uninstalling and reinstalling a bunch of drivers (even tried installing the factory-default NVIDIA driver) and software (including the VAIO event service), but it doesn't work.

Any idea how to fix this?

share|improve this question
    
Also tagging as Windows XP since it fixed the same problem on XP as well. –  Mehrdad Mar 14 '12 at 7:23
    
This also happens when installing TeamViewer as it adds its own monitor driver –  EionRobb Jul 29 '13 at 0:40

1 Answer 1

up vote 13 down vote accepted

Navigate to Start -> Control Panel -> Hardware and Sound -> Device Manager.

In the Device Manager window, look for “Monitors”, then right-click your monitor and select “Uninstall”. Be sure to also check the “Remove driver” option. Once removed, click the “Scan for hardware changes” icon. Doing so should bring the brightness settings back.

For both NVIDIA and ATI drivers for Sony Vaio, after performing this solution, you can restore the brightness via the Mobility Center (Windows+X).

share|improve this answer
    
Thanks so much, this is awesome!! :D Now I remember I had done this before... I needed the Generic PnP Monitor driver to be installed, not PnP Monitor (Standard). (It didn't automatically install, probably because I didn't select the "Remove Driver" checkbox for the previous driver, so I selected it manually -- but once I read your post I figured that's what the problem is.) Thanks again! –  Mehrdad Mar 14 '12 at 1:20
    
Glad the problem solved! You're welcome. –  Mehper C. Palavuzlar Mar 14 '12 at 10:25

protected by Community Aug 12 '12 at 20:59

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.