Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I recently bought a desktop computer with Windows 7 Home Premium x64 preloaded (OEM). I tried to install Windows 7 Ultimate x64 on this computer but I was presented with the following error message:

Windows cannot be installed to this disk. The selected disk has an MBR partition table. On EFI systems, Windows can only be installed to GPT disks.

The 1TB HDD on this computer has three partitions:

  1. SYSTEM 100 NTFS - Healthy (System, Active Primary Partition)
  2. OS (C:) 9148.04 GB NTFS - Healthy (Boot, Page File, Crash Dump, Primary Partition)
  3. HP_RECOVERY (D:) 13.37 GB NTFS - Healthy (PrimarynPartition)

I'm trying to install a clean copy of Windows.

share|improve this question
Are you able to get into the windows install screen where you select which drive you want to install windows on? it's the advanced drive setup screen. I believe you're given a choice over upgrading or installing fresh. – Dez Mar 14 '12 at 1:51
Yes. I get stuck when I choose which hard drive I want to install Windows in (the 'next' button is grayed out) View here:… – Joe Morales Mar 14 '12 at 2:40
If windows installation disk does not give you option for fresh install then you can try one of these 2 options: 1) start windows install after logging in to the existing installation (upgrade option) or - 2) use a live CD (linux or windows based) to first erase everything on disk or at least delete the partition table. – Alex Mar 14 '12 at 3:15
possible duplicate of Windows detects GPT disk as MBR in EFI boot – JdeBP Feb 6 '15 at 10:32

You will need to delete the partitions, create a new partition with the unallocated space, then choose that drive to install Windows on.

share|improve this answer
this was the perfect solution for me, no messing with bios or anything else. Simply delete existing partition since all data was junk anyway and everything worked. – DXM Nov 18 '12 at 8:16

It occurs so because the Windows DVD was booted in UEFI mode. If you really want to keep your existing partitions, then switch your firmware to MBR/BIOS mode and retry the installation, it should allow you to install on your existing (MBR) volume.

In case your firmware does not have any such visible option, your next option is to launch the installation from the existing Home Premium Windows: just start the Setup executable and follow the screenss, it should figure out correctly the kind of installation (UEFI vs MBR) you are doing.

Another possibility which I have seen advised is to reburn the Windows DVD without the UEFI (0xEF) bootstrap; to answer kreemoweet's question, this is quite likely the way it HomePremium was installed in factory in the first place: the firmware favours UEFI over BIOS when it sees both bootblocks, as is the case of the retail DVD, but will use whatever is proposed if only one of them is given; and the way Windows is started (UEFI, resp. BIOS) directs the kind of partitioning is acceptable (GPT, resp. MBR) to install Windows x64.

share|improve this answer

I changed the boot sequence and it works.

I booted into BIOS and then made UEFI be the last boot option, just after hard disk, and then it works!

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .