Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm attempting to forward all traffic through from Google Chrome through a SSH tunnel.

When Firefox is configured to use the tunnel, it works. When chrome is launched with the proxy args appended, it quickly causes the ssh process to lock up and the pages timeout.

Client:

  • OpenSSH_5.8p1 Debian-7, OpenSSL 1.0.0d 8 Feb 2011
  • Google Chrome 17.0.963.79

Server:

  • OpenSSH_5.9p1 Debian-3ubuntu1, OpenSSL 1.0.0g 18 Jan 2012

Server config;

~$ cat /etc/ssh/sshd_config
...
PermitRootLogin no
AllowUsers testuser
ClientAliveInterval 60
ClientAliveCountMax 5
GatewayPorts yes
MaxSessions 100
#MaxStartups 100    

Client connected using ~$ ssh -v -D 8118 testuser@example.net

Chrome executed with ~$ google-chrome --proxy-server="socks5://localhost:8118"

debug1: Connection to port 8118 forwarding to socks port 0 requested.
debug1: channel 3: new [dynamic-tcpip]
debug1: Connection to port 8118 forwarding to socks port 0 requested.
debug1: channel 4: new [dynamic-tcpip]
...
debug1: Connection to port 8118 forwarding to socks port 0 requested.
debug1: channel 51: new [dynamic-tcpip]
debug1: Connection to port 8118 forwarding to socks port 0 requested.
debug1: channel 52: new [dynamic-tcpip]

Pages loaded in chrome report; Error 7 (net::ERR_TIMED_OUT): The operation timed out.

The client side ssh process locks up and has to be killed.

share|improve this question
add comment

2 Answers

up vote 0 down vote accepted

I ended up fixing this by using Privoxy

I setup Privoxy on the ssh server (defaults to listen on 8118)

then connected to the server using; ssh user@example.net -L 8118:localhost:8118

Then set chrome to use localhost:8118 across all protocols

Note: after setting up privoxy, use http as the scheme in chrome/firefox

share|improve this answer
add comment

I had the same problem.. It worked in Firefox (and check that it works in Firefox.. 'cos there is a setting in firefox to not use the proxy when doing a local address...so it can look like it works when it isn't, but here, it was working and I think it was working for you too. But as you say, not in Chrome)

For me, the key was doing socks5:// before the IP. Otherwise It just assumes it's a regular HTTP Proxy.

In Chrome, there are two ways I have run into of setting it to use a Proxy, including, a SOCKS Proxy..
a)setting it "within the browser"
b)setting it from the command line

To get it set from the browser, look where it normally asks for the IP and Port (wrench..settings..under the bonnett/hood..change proxy settings..LAN..)

Then where it asks for an IP and Port- Don't just put an IP for IP. Put socks5://ip or I suppose socks4:// if it's socks4. This may not work for IE

You can also tick the box that says use a proxy, then leave the field blank, click advanced, and enter the IP and Port for the SOCKS proxy in the box labelled SOCKS. This works for IE too.

You can see it's set by going to chrome://net-internals

To set it from the command line (use Everything by Voidtools to help you find the path!)

C:\Documents and Settings\name\Local Settings\Application Data\Google\Chrom lication>chrome --proxy-server="socks5://192.168.1.5:1234"

You can use netstat -aon look for lots of connections to your Proxy port 1234 established, and there shouldn't be any connections to port 80 , if there are do tracert on them, they may be things you know that aren't from your web browser like dropbox or maybe logmein and so check that the browser is getting its pages through the proxy.

this link was helpful http://code.google.com/p/chromium/issues/detail?id=38207

share|improve this answer
    
chrome://chrome-urls/ –  barlop Apr 27 '12 at 0:35
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.