Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The problem: I have an HP printer, networked over CAT 6. It prints, but every other page is a blank page.

No, I do not have this option turned on under Printer settings on windows. I know it's not a settings problem with Windows, as when I plug in the Printer directly to my computer, it does not print the blank pages.

Here's my network setup:
Modem -> Wireless Router -> Switch -> Printer

All devices connect directly to the Switch via CAT 6 cable.

I've talked to HP several times, but they don't seem to know the solution, has any one else had this problem?

I thought it was the printer, but it's happened to every HP printer I tried to network.

I'm thinking there might be a problem with packets being sent over the network...


Update:

The problem goes away with Windows 7. There must be a problem with the default Windows Vista driver.

share|improve this question
    
What kind of printer is it? –  JFV Jul 15 '09 at 23:07
    
Well, it's happened to about 3 HP printers now, but my current one a HP Photosmart D7460. –  Jefe Jul 16 '09 at 0:02
    
When you say directly hooked up to your machine, do you mean through usb or network cat 6 directly to the computer? –  Troggy Jul 21 '09 at 23:53
    
@Troggy good question. When I hook it up to my machine using a USB. I suppose I could hook it up using a cat 6 and see what happens. –  Jefe Jul 22 '09 at 14:31
    
@Jeje yah, because the machine uses different drivers/interface for usb vs network setups. –  Troggy Jul 23 '09 at 17:53
show 1 more comment

4 Answers

up vote 3 down vote accepted

This is a Driver issue. Get the latest driver for your system and make sure you are using the correct protocol/port to connect to the printer.

Make sure you choose the right driver for your printer. (PCL or PostScript)

If you are using postscript the following applies. In some cases printing elaborate postscript documents can also have this result when the printer needs more memory to properly render the document.

share|improve this answer
    
Thanks for the suggestion. It has the same results on XP, Vista and Windows 7; so I'm not convinced it's a driver issue, but I'll give it a spin. –  Jefe Aug 14 '09 at 3:34
    
The problem goes away with Windows 7. There must be a problem with the default Windows Vista driver. –  Jefe Aug 25 '09 at 2:25
add comment

If your drivers are up-to-date try to disable DEP (Data Execution Prevention).

share|improve this answer
    
Thanks for the answer. I'll give that a try next time I have access to the printer :) –  Jefe Jul 20 '09 at 23:49
add comment

When you connect via USB, Windows will install a new copy of that printer. In other words, if there is in fact a setting that is causing this it shouldn't be present on the printer configuration.

I have two suggestions:

  1. Go through every page of each printer properties for the two printers, and ensure nothing is different except for the port. Keep in mind that printing preferences and printing defaults both need to match up. I've seen cases where one or the other was not set correctly, resulting in undesired behaviour.

  2. Copy the USB installation in your printers folder, and change it's port to use the TCP/IP port used by your network printer - see if this corrects the issue.

If #2 does not correct the issue, and the problem continues then it is a problem with the driver or the printer. What model printer, and have you obtained the latest driver? Perhaps an older version of the driver (if you can find such a beast) is available?

Failing that - delete all of the drivers and ports related to the printer. (Right Click in Printers -> Server Properties -> Delete each driver for this printer, then all the ports) and reset the printer to factory defaults. Then reinstall using the latest driver from HP.

And if that doesn't work ... you have a bodgy printer :)

share|improve this answer
add comment

I've seen this before on HP printers, but I don't have a networked HP printer available to look at right now. I'll check it out tomorrow and let you know what I find out.

EDIT: Sorry for the long wait, had some health issues to attend to...

Check under 'Ports', select the IP port that the printer uses and click the 'Configure Port...' button. In there, check to see if the print protocol is 'Raw' under 'Port Number' 9100.

Let me know if that helps you out.

-JFV

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.