Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to change the file-format of New Text Document to html.But the file-extension was changed and still it open as a .txt file.

share|improve this question
1  
How are you trying to open the file? Have you got the "hide known extensions" option checked? –  ChrisF Mar 14 '12 at 11:18
    
just i click the context-menu and created the new text doc and tried to rename and change the file-format to .html –  Vijin Paulraj Mar 14 '12 at 11:24
    
@ChrisF, What does it hide known extensions? –  Vijin Paulraj Mar 14 '12 at 11:24
1  
I'm not on XP so I can't remember exactly where the option is, but if you hide extensions when you try to rename you might end up with file.html.txt which will still be a text file not a html file –  ChrisF Mar 14 '12 at 11:26
    
@ChrisF,exactly the same problem!!!! –  Vijin Paulraj Mar 14 '12 at 11:27

3 Answers 3

up vote 6 down vote accepted

Based on your comments you appear to have "Hide extensions of known file types" set.

This means that when you create a new text file you see:

NewFileName

rather than:

NewFileName.txt

This also means that when you rename the file all you are changing is the filename part, but not the extension. This means that Windows still treats the file as a text file rather than html file. What you have is a file called:

NewFileName.html.txt

Turn off this option. Full details can be found here but you need to go to Folder Options and select the View tab. Then find the "Hide extensions for known file types" option and clear it:

enter image description here

share|improve this answer
    
thanks Chris...awesome! –  Vijin Paulraj Mar 14 '12 at 11:34

do : right click on the file and choose open with and select internet explorer

share|improve this answer
    
it was opened with .txt extension in my browser. –  Vijin Paulraj Mar 14 '12 at 11:26

Alternatively, if using notepad or some similar editor to edit the file, make sure that you are saving as type "All Files (.)", with the extension ".html", and save as "filename.html".

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.