Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've been using a Logitech Cordless Desktop MX3100 keyboard for quite a while. I've never really had any problems, except for the occasional typo.

I noticed however that I tended make the typo "Laod" instead of "Load", quite a bit more often than any other typos. As it started to get on my nerves, I decided to do some testing.

What I found out was than when I write lowercase "load", I'd never make the typo. All uppercase, or just uppercase L, I'd make the typo quite often. My actual (very scientific) testing is probably best described by showing the output:







What i found out was that whenever shift was depressed, typing an uppercase "L" would induce a significant lag if the next character was an "o", compared to the lag of the any other key:

High "o" lag:

No "a" lag:

No lag for neither "o" nor "a":

By realizing this I regained a slight bit of sanity as I knew I wasn't coming down with a case of Parkinsons. I was actually typing correctly, the lag just interpreted it wrongly.

Now, what really bugs me is that I can't fathom how this is occurring. What I'm actually typing, in physical order, is this: L - o - a - d, and yet, the "a" is output before the "o", even though "o" was pressed before "a".

So while the keyboard is processing the "Lo" combo, the "a" gets prioritized and is inserted before the "o" is done processing, resulting in Laod instead of Load. And this only happens when typing "Lo", not when typing lowercase "lo".

This problem could stem from the keyboard hardware, the receiver hardware or the keyboard software driver. No matter the fault location however, I can't imagine how this could be implemented as anything but a FIFO queue. A general delay, sure, I could live with that, albeit I'd be irritated. But a lag affecting different keys differently, and even resulting in unpredictable outcome - that just doesn't make any sense.

I've solved the problem by just switching to a wired keyboard. I just can't shake it off me though; what kind of bug/error/scenario would result in a case like this?

Edit: It's been suggested that I stop drinking Red Bull and stick to water instead. While that may actually help solve the issue, I'm really not looking for a solution as such. I'm more interested in an explanation of how this could happen, as I can't imagine any viable technical solution that could result in this behavior.

share|improve this question

Something that comes to mind is to refer to the keycodes the wireless keyboard sends and delays involved:

Each key pressed sends both a DOWN and UP code...

  • You press SHIFT, it sends 'SHIFT-DOWN'
  • press 'l', sends 'l-DOWN'
  • release 'l', sends 'l-UP'
  • release SHIFT, sends 'SHIFT-UP'
  • press 'o', sends 'o-DOWN'
  • release 'o', sends 'o-UP'
  • press 'a', sends 'a-DOWN'
  • release 'a', sends 'a-UP'
  • ... and so on

It sounds like the Logitech wireless has something affecting it during sending of shift strokes (or maybe 'modifier' strokes... ctrl, shift, alt..)

I have a Logitech wireless keyboard (Model K270) and haven't noticed anything like this, although I know from my own typing style I FREQUENTLY mistype 'make' as 'maek' and 'mkae'... it's me, I'm consistent over every keyboard and computer I write code on... so I've added aliases to bash and vim so I don't get (figuratively) whacked in the head everytime I do this.

Is it a visible or perceptible lag? Only happen based on your typing speed?

I'm going to shotgun ideas here: random things I can think of that might be relevant...

  • possible wireless interference for that particular bitpattern sent? Have you tried re-syncing the wireless to the receiver?
  • possible key-matrix interference since 'L' and 'O' are usually on the same 'column' line? (could be row... but you get the idea)
  • You have the extraordinarily rare and possibly lethal 'L-a-o' virus. (Haven't heard of it? Told you it was rare...)

I'd try re-syncing the keyboard to the receiver, no, I don't know either way, but stranger things have worked for less. Can't hurt? Right?

share|improve this answer

I'd normally write this as a comment but I don't have enough reputation, so I'll make this as helpful as I can.

I have a very similar problem, except my delay comes from the OM combination.

I'll sometimes write FROM (in a database query), and my SPACEBAR stroke will process first and I'll end up with FRO. Not quite the same problem, as my M never actually comes through, but very similar. Also, it only does it when I hold SHIFT. If I'm instead using CAPSLOCK, the delay is not there. Alternatively, when CAPSLOCK is enabled, and I hold SHIFT, then the lowercase o and m cause the same delay. The issue definitely lies with SHIFT.

I also have a logitech keyboard, although it's a G110, and it's wired;

I just tested your specific scenario and I have no issues with it, so each keyboard model (or its corresponding driver), must have its own inconsistencies, and, for whatever reason, not properly update the queue of keystrokes. (Assuming like you said that it is a queue, and I wouldn't see why not).

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .