Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I was trying to read this post, but it looks like this:

bad display

How can I get my web browser to display this post correctly?

I'm using Chrome 17.0.963.78, Firefox 10.0.1, and Safari 4.0.5 on OS X 10.5.8. All three fail in the same way on this post. A solution for any one of them is fine.


Update:

after following @Jukka's instructions and installing the Symbola font, it looks like this (on Chrome):

maybe fixed

Is this correct?

share|improve this question
add comment

2 Answers

Download and install the Symbola font. This is character rendering issue: the post contains, apparently for fun, rarely used characters which are not present in most fonts; they are partly iconic symbols, partly variants of letters coded as mathematical symbols in Unicode (e.g., mathematical bold fraktur letters). Symbola seems to be the only font available that contains all of them.

share|improve this answer
    
That definitely improves it. I've add my current status to the OP; is that what it's supposed to look like? There are still a few boxes appearing. –  Matt Fenwick Mar 15 '12 at 19:11
1  
The remaining boxes should be icons like camels, and Firefox on Win 7 shows them that way but Chrome doesn’t but produces appearance like in your new screen shot. Apparently Chrome is not able to use fonts to the fullest extent without help. It possible misreads information in other fonts, expecting them to support these characters, and thus does not use Symbola for them. If I add the style sheet h1 { font-family: Symbola !important }, even Chrome gets it right, –  Jukka K. Korpela Mar 15 '12 at 20:27
add comment

My Safari 5.1.3 on 10.7.3 displays all characters properly, and I haven't installed any additional fonts. The fraktur characters are included in STIXGeneral, and the emoji characters in Apple Color Emoji.

I guess you are still on 10.6 or 10.5? In any case, Lion should come with the STIX fonts and support emoji out of the box.

Chrome doesn't support Emoji at the moment though, see lion - Why do emoji like 💩 appear when I use Safari, but not Chrome? - Apple - Stack Exchange.

share|improve this answer
    
5.1.2 on 10.6 doesn't display them correctly as well. –  slhck Mar 15 '12 at 11:34
    
Yes, I'm on 10.5.8. Forgot to mention that. –  Matt Fenwick Mar 15 '12 at 12:00
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.