Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

How can I call an x86 application in the Program Files (x86) folder from the x64 command prompt? The x86 exe functions w/o problems on a x64 Win XP, but how to call it from a command propmt?

>> C:\Program Files (x86)\theExe.exe


>> cd C:\Program Files (x86)\
>> theExe.exe


>> start "C:\Program Files (x86)\theExe.exe"

Neither of the above worked ...

==== Edit : I changed the title, and will state basically an extended question:

It turns out that the problem goes a little further ... If I have to start PDFCreator.exe like the answer below, and like suggested on their web site, It should go like this:

"C:\Program Files (x86)\pdfcreator.exe /IF\"C:\\" /OF\"C:\description.pdf\"" 

(considering treating quotation marks as literals, i.e. using the escape character '\'). However, it will refuse to start, stating no such command... Any idea?

share|improve this question
Windows' command line escape character is ^, not \ . That may help. – Bob Mar 15 '12 at 10:48

You just need to enclose the line in quotes:

>> "C:\Program Files (x86)\theExe.exe"

Window cmd uses space to delimit commands and parameters and so enclosing with quotes tells the parser to ignore any spaces between the quote marks, and accept the entire thing as a command.

share|improve this answer
Thanks, Im giving you the point (If I could, dont have enough reputation). However, it turns out that the problem goes a little further ... If I have to start this one: "C:\Program Files (x86)\pdfcreator.exe /IF\"C:\\" /OF\"C:\description.pdf\"", it refuses to start it. Any idea ? – HeinrichStack Mar 15 '12 at 9:03
@HeinrichStack as the other answer states (and my own), the quotes should enclose the executable and its path, not the parameters. – Paul Mar 15 '12 at 10:49

Close the quotes at end of pdfcreator.exe and replace \" with "

Try running as mentioned below:-

>> "C:\Program Files (x86)\pdfcreator.exe" /IF"C:\" /OF"C:\description.tif"
share|improve this answer
Thanks, but that wont worked. I had already tried this. – HeinrichStack Mar 15 '12 at 10:24
@HeinrichStack: Whats the error message you are getting? – Siva Charan Mar 15 '12 at 10:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .