Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

With firefox 11 there is a new feature called 3D page inspector which I would like to test because I think is really useful.

However, I can't really find where this should be enable or how to do it!

Can anyone help me with this? I'm going mad

share|improve this question

7 Answers 7

up vote 12 down vote accepted

Invoke the Element Inspector using Ctrl+Shift+I or by clicking the appropriate menu item:

enter image description here

Now, pick an element on the page (optional):
enter image description here

By clicking the 3D button, you'll get the desired 3D view: enter image description here

There is no "3D" button/It doesn't work. What now?

Firefox uses WebGL for the 3D view.

To my understanding, this feature was also previously available in the form of the Tilt addon. The blog says:

Available as an addon

The latest version of Tilt can be found on Github, but you can also download Tilt as an addon from addons.mozilla.org.

For compatibility, Tilt requires WebGL capabilities. Go to get.webgl.org to check availability and troubleshoot any issues. The current version works with Firefox 6.0 to latest 10.0 Nightly releases (latest Nightly builds now also support WebGL anti-aliasing, working great with Tilt).

To start Tilt, hit Control+Shift+M (or Command+Shift+M if you’re on Mac OS), or go to Web Developer -> Tilt, available in the Firefox application menu (or the Tools menu on Mac OS). You can modify this hotkey (and other properties) from the Options menu after starting Tilt.

share|improve this answer
Thanks!!! In the Italian localization is a bit hard to understand that the 3D view is in that function!!! Is beautiful –  Fire-Dragon-DoL Mar 15 '12 at 12:14
I don't have the 3D button. –  kitsched Mar 20 '12 at 16:09
@kitsched I would assume it requires WebGL support or something similar. You could open a new question and see if someone knows. –  Oliver Salzburg Mar 20 '12 at 16:14
I cannot for the life of me find the 3D button. It simply isn't there! I have installed FF11 on three different computers with the exact same result! All I can see is the HTML and Style buttons. –  Diego Deberdt Mar 20 '12 at 22:18
As Oliver Salzburg mentions, go to get.webgl.org and see what it says. In my case it said that WebGL is disabled on my system. –  ShankarG Mar 27 '12 at 9:19

I had this working previously, but in FF 30.0 it was disabled for some reason. The new style button is different from the "3D" button in other answers - now it's a cube icon. It didn't appear until I manually enabled the option in the Developer Tools.

enter image description here

share|improve this answer

To enable webgl on FF (i.e. 11) go to address "about:config" in browser, put "webgl" in Search box, dblclick (set to True) setting "layers.acceleration.force-enabled"

share|improve this answer

Nothing worked for me except this:

  • Go to about:config
  • Set webgl.force-enabled as true.
  • Set webgl.msaa-force as true.
  • Set layers.acceleration.force-enabled as true.
  • Set gfx.direct2d.force-enabled as true.

Source: http://techawakening.org/firefox-11-3d-inspect-button-not-working/946/

share|improve this answer

I'm on Firefox 20 and I could the message "could not initialize tilt". I updated firefox then created a new variable in about:config called "webgl.enabled_for_all_sites", set it to true, and it worked! source of help: http://www.nextofwindows.com/how-to-enable-webgl-in-firefox-chrome-and-safari/

share|improve this answer

View Surf Website in 3D using Firefox Tilt Inspector


share|improve this answer
Please quote the essential parts of the answer from the reference link, as the answer can become invalid if the linked page changes or the target site is unreachable/permanently offline. –  DavidPostill Oct 30 '14 at 13:34

I had the problem where the 3D view button appeared for chrome-only tabs (e.g. about:config) but was not accessible on normal content tabs. At first I thought that my graphics driver had been blacklisted, but fiddling with the about:config options listed in other answers here did not change this behavior.

It turns out that, at the time of writing this answer (13 Nov 2014), the Nightly builds of Firefox do not show the 3D view option on content tabs when running with Electrolysis (e10s, multi-process) enabled. Mozilla bug 937166 tracks the work necessary to make the 3D view remotable across the content processes.

As a workaround, disable the multi-process mode from the General tab in the browser preferences:

'General' tab of Firefox (Nightly) preferences window, showing the 'Enable E10S' checkbox

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.