Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a ClickOnce application that is published to an IIS web server and the install page and installation process has been working perfectly for years.

One of my new users has recently tried to go to our installation page and he is now getting the following error message:

Error Code: 403 Forbidden. The server denied the specified 
Uniform Resource Locator (URL). Contact the server 
administrator. (12202)

I've tried to Google this specific message, yet everything I can find regarding fixing it involves changing settings on my server or running hotfixes. However, this isn't/shouldn't be a problem with my server because the page has loaded for years and both I can access this site, as well as other user's who work at and are connected to the same network and facility that this gentleman is located at.

What tips can I provide to him that could help him troubleshoot this problem?


FYI, this user that I am mentioning is not part of the same network that I am in. He works for another company and is trying to install an application that we provide as a service.

What is unique about this user is he works in the same building, on the same network with the same firewall software installed on his PC as a few other users. As a test, he's managed to get a couple of them to load my web page, and they are not having any trouble. So, this seems to be a specific problem with his PC.

Since I'm not an admin on their network, I can't do any thing to fix this problem. However, I would like to at least help steer him in the right direction.

Could this be a problem with a server some where between his PC and our Server here? Possibly his request is bouncing through some gateway that just doesn't like my address? I'll be honest, I have a moderate understanding of these type of configurations. Our ISA server is managed by another IT group and I don't even have access to the machine. I do know, however, that they haven't changed anything on the server for at least a couple years.

share|improve this question
This sounds like a setting on his personal pc. The simplest way to solve a problem like this is to wipe it. You also did not indicate what browser he is using. – Ramhound Mar 15 '12 at 16:13
up vote 2 down vote accepted

Maybe the access is granted to a specific group in your AD only, and the new user is not in that group? You should check the IIS logs for details:

share|improve this answer
This isn't the problem. This application is available from a internet web address, not from within our intranet. The page is, thus, accessed by account associated with the web server instance. Again, this has been working for years, without problem and there is only this one user who is having trouble. This user works for another company and is not connected to our network in any fashion. – RLH Mar 15 '12 at 16:01
can you make sure then the error is produced by your IIS and not any kind of proxy on the user's site? – user4711 Mar 15 '12 at 16:02
Alexander-- How would I do that. I would imagine it is a proxy issue, but wouldn't other users on his network (who should be going through the same proxy) see the same error message? – RLH Mar 15 '12 at 16:07
Definitely sounds like a proxy or firewall server on the client's end blocking your download server. Common practice in business environments. – BBlake Mar 15 '12 at 16:21
@BBlake-- I'll mention it to him. Unfortunately, I doubt that means he will be able to find a way to fix the problem. Thanks, though, for the expertise. – RLH Mar 15 '12 at 16:34

Is the user at a site off the local LAN? Possibly behind an MS ISA (Proxy/Firewall/Security) server? The ISA rules could create this scenario/error. This could be specific to the end user site and not an issue that you can directly address

As many firewalls like ISA can be configured for specific users or IP ranges, the fact that one user works and another does not is possible.

check that the suer with the issue is running similar patch levels and that there are no local firewall apps that are different from the users taht work.

share|improve this answer
Please see my update and my comments that I made on Alexander's post. – RLH Mar 15 '12 at 16:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .