Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I installed Linux Mint 12 KDE, and I would like to check the root partition for any errors.

How do I check the root partition with fsck at boot time?

share|improve this question

4 Answers 4

up vote 23 down vote accepted
sudo touch /forcefsck

Then reboot.

share|improve this answer

You can use shutdown command for this too.

shutdown -rF now

From man:

The -F flag means 'force fsck'.
This only creates an advisory file /forcefsck which can be tested by the system when it comes up again. The boot rc file can test if this file is present, and decide to run fsck(1) with a special `force' flag so that even properly unmounted file systems get checked. After that, the boot process should remove /forcefsck.

share|improve this answer
    
I tried this with Linux Mint 15 MATE and it didn't cause a check when rebooting. But sudo touch /forcefsck worked when I did that before sudo reboot. –  Colin D Bennett Nov 6 '13 at 16:54
1  
shutdown supplied with Upstart does not support the -F option any more. You should use sudo touch /forcefsck instead. See for example Why was -F removed from /sbin/shutdown? and Bug #74139: shutdown missing -F (force fsck) option. –  pabouk Oct 14 '14 at 10:48

Here is another way to do this:

tune2fs -C 2 -c 1 /dev/THEDEVTHATROOTIS

reboot

then the filesystem will be checked, and once all is good you should do

tune2fs -c 60 /dev/THEDEVTHATROOTIS

I have assumed that the max-mount-count was set to 60, you should find out before issuing the first command with

dumpe2fs /dev/THEDEVTHATROOTIS |grep "Maximum mount count"

share|improve this answer
    
your answer is good and ... should work most of the time (I mean on most of standard installed Linux) BUT, you ASSUME that root partition is ext2,3,4 formatted, what if is something else like xfs or reiserfs ? :) –  THESorcerer Sep 14 '14 at 8:17
    
True this is a 9/10 solution. –  g24l Jan 28 at 9:38

On modern linux systems the answers above (with forcefsck) don’t work. You have to do it manually:

  1. Put your root partition into read-only mode by modifying the faulty partition’s line on /etc/fstab (but remember your old settings):

    UUID=fd1d0fad-3a4c-457f-9b5e-eed021cce3d1 /                       ext4    remount,ro        1 1
    
  2. Reboot

  3. Switch to runlevel 1 just to minimize the amount of interfering processes:

    init 1
    
  4. Fix your file system (replace /dev/sda2 with your partition’s device), which should now work because the root partition is in read only:

    fsck /dev/sda2
    
  5. Reboot. (On my Fedora 21 system I had to change to runlevel 1 during boot with Grub2, because otherwise the system was stuck due to not being able to write on the root-partition)

  6. Make your root file system readable/writable:

    mount -o remount,rw /dev/sda2
    
  7. Restore your /etc/fstab to its original state.

  8. Reboot


Source: http://bitsofmymind.com/2014/03/14/how-to-fix-fsck-your-root-file-system-that-you-have-to-boot-into-on-linux/

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.