Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

GC version: 18

Default GC search engine setting looks like this:

{google:baseURL}search?{google:RLZ}{google:acceptedSuggestion}{google:originalQueryForSuggestion}{google:searchFieldtrialParameter}{google:instantFieldTrialGroupParameter}sourceid=chrome&ie={inputEncoding}&q=%s

It's searching on Google Search in my country. How do I change that to always use Google US? I've tried to set the default setting to:

http://www.google.com/#hl=en&q=%s

This works except when using some symbols like plus sign '+', since it's not escaped. For example, if I type '123+456' in address bar, it will be interpreted as http://www.google.com/#hl=en&q=123+456, which would do google search '123 456', not the calculation result 579 I was looking for. Another example is that searching 'C++ bit operation' would get google search 'C bit operation'. This issue makes address bar searching not working in some cases. I was wondering if there's any way to resolve this?

share|improve this question
    
Windows, Mac OS or Linux? – JohannesM Mar 16 '12 at 10:14
    
Windows 7. Chrome v18 – Stan Mar 16 '12 at 15:36
    
did you allready tried this one? groups.google.com/a/googleproductforums.com/forum/… – JohannesM Mar 16 '12 at 15:49
    
Yep, the %s variable can only take non-url specific characters, meaning that '+', '&' are all treated as part of url. – Stan Mar 16 '12 at 18:17
2  
did you try http://www.google.com/search?{google:RLZ}{google:acceptedSuggestion}{google:ori‌​ginalQueryForSuggestion}{google:searchFieldtrialParameter}{google:instantFieldTri‌​alGroupParameter}sourceid=chrome&ie={inputEncoding}&q=%s ? – Rob Mar 16 '12 at 18:26

You need to edit the file

Local State.txt

in your chrome directory.

Chrome's default directory can be found out here : chrome://version/ [Copy and paste this in the URL bar] (The profile path)

Edit the local state file there and replace google.xxx (Your country's extension) with google.com in the browser field "last_known_google_url" and "last_prompted_google_url"

googleeeee

Replace google.co.in with google.com

share|improve this answer
    
This seems not to be working. My last_known_google_url and last_prompted_google_url are both "www.google.com". I was trying to grep 'baseURL' in default directory as {google:baseURL} looks like a environment variable in the configuration. But I didn't find one. – Stan Mar 16 '12 at 15:38
1  
@Stan I changed it to google.com and it worked fine for me, I am using Chromium not chrome, if that makes any difference. – HackToHell Mar 17 '12 at 4:14
1  
Thank you, you can't imagine how much stress this was producing!! It is amazing how much the results suck in Spanish for technical problems and programming!! Thanks! – Trufa Mar 29 '12 at 2:53
up vote 2 down vote accepted

According to Rob's comment, set the default search engine to https://www.google.com/search?{google:RLZ}{google:acceptedSuggestion}{google:ori‌​ginalQueryForSuggestion}{google:searchFieldtrialParameter}{google:instantFieldTri‌​alGroupParameter}sourceid=chrome&ie={inputEncoding}&q=%s to resolve this issue.

share|improve this answer

You better do the following:
How to fix:

  1. Open "C:\Users{your_user_account}\AppData\Local\Google\Chrome\User Data" folder.
  2. Open "Local State" file.
  3. Add/Edit these in the node "browser":
    "last_known_google_url": "https://www.google.com/", "last_prompted_google_url": "https://www.google.com/",
  4. Open "Default/Preferences" file.
  5. Add/Edit these in the node "browser":
    "last_known_google_url": "https://www.google.com/", "last_prompted_google_url": "https://www.google.com/",


How node "browser" looks like:
  },
  "browser": {
     //your code here


I figured that out after a lot of investigation in my Chrome installation directory, as I couldn't find any workable solution by Googling the problem, so I prefer to share it :)

share|improve this answer

Try adding a space between the terms, i.e. 123 + 567, although it works on my version of chrome even without them.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .