Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Trying to install an App or Extension in Chrome Web Store fails. Console Message is this.

I don't "cancel the install". It says: "checking.." (grey) and then there is the blue install button again. No app or extension installed.

share|improve this question
up vote 4 down vote accepted

I kept getting stuck on "checking" while trying to install extensions. Poking around I found the download directory was set to "F:/Driver" for some reason. That path doesn't exist on my system. I set it to a valid directory, and it started working.

share|improve this answer
same here, download directory wasn't accessible. – mrzmyr Apr 8 '12 at 21:12

If the web store is giving you errors, you can directly download apps/extensions by copying the app ID and going to this link:

You will want to replace "~~~~" with the app ID. You can find the app ID in the URL bar of the app on the Chrome Web Store. It will look like a random string of letters between a slash and a question mark.

If you do this, it will directly download the file. You can go to your extensions page and drag it on and it may install.

If it still doesn't install, change the file extension to ".zip" and extract it into a new folder and delete the zip file. Then go to your Extensions page, click "Developer mode", and click "Load unpacked extension" and click the folder you extracted it into.

This is how I install things if the Chrome Web Store isn't responding. You can also view the source code of the app like this.

share|improve this answer
This doesn't seem to work anymore. I get a 204 No Content response when navigating to the URL with the correct app id, for example I used this url for this extension – Vicky Chijwani Jun 28 at 16:14

Downloads folder - as described in other answers - did not work for me.

However disconnecting my Google account and connecting it to Chrome once again fixed an issue.

share|improve this answer

The instructions are for Windows, but worked on my Mac as well:

Workaround For Google Extensions Stuck In CHECKING

  • Click the wrench icon toward the top right of your browser.
  • From the drop-down menu select, “Settings”
  • In the Search settings textbox toward the top center, type “downloads”. A Search results page shows similar to the one below.
  • Check that the Download location: folder is correct. In my case, the text box was blank.
  • Click Change… and navigate to your new folder.
  • Make sure that your entry sticks.
  • Try to install the Google Chrome extension again.
share|improve this answer

If all else fails. don't use the Web Store install routine - do it manually.

Download the extension file from the author's website and save it to your computer. Usually this is a zip file found at GitHub. Just click the Website link in the Chrome Web Store display for the extension and follow your nose.

Unpack/zip the zip file. It will unpack into a folder. The zip may contain multiple extensions by the author - find the folder containing the files for the extension you want.

Open Chrome's Extensions page in Settings. Enable Developer Mode. Click "Load unpacked extension" button. Navigate to the folder containing the extension's file. Click OK, it will install the extension.

share|improve this answer

How about adding any extension manually:

  1. Open
  2. Copy and paste URL of any google extension in search bar.
  3. It will download extension in ( crx ) format.
  4. After downloading go to chrome settings and then click on extensions from settings, this is the area where extension are installed.
  5. Now drag the downloaded extension (crx) to google chrome extension area.
  6. Google chrome will give you an option. DRAG TO INSTALL
  7. Drag it and enjoy
share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .