Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've set up Postfix on my server along with Squirrel Mail. However, every time I go to send an email to my Gmail account from the server the email never arrives. I get no bounce back emails, I get no emails in Junk. Nothing.

I've checked my maillog and I have found the following line:

Mar 16 07:55:23 setanta postfix/smtp[17339]: 64F235F83: to=<myemailaddress@gmail.com>, relay=none, delay=0.07, delays=0.07/0.01/0/0, dsn=4.4.1, status=deferred (connect to
127.0.0.1[127.0.0.1]:10024: Connection refused)

In the /etc/postfix/main.cf I have changed the following:

inet_interfaces = all
inet_interfaces = $myhostname
inet_interfaces = $myhostname, localhost
inet_interfaces = all

I have removed # from each one of these options one at a time, restarted Postfix each time, but I still get the Connection Refused error. I don't know if it makes any difference, but when I go to send emails to this server the emails are never delivered either. But I get no bounce back emails either.

share|improve this question
    
Some ISPs block port 25 for customers to prevent spamming and require you to use an smtp-relay. –  micke Mar 16 '12 at 12:41

1 Answer 1

up vote 0 down vote accepted

This error was caused by the amavisd service not being started. Once it was started it worked fine.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.