Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Since a recent windows update, I've been unable to run almost any program (including firefox, ie and origin) due to the following error:

The application has failed to start because it's side-by-side configuration is incorrect. Please see the application event log or use the command-line sxstrace.exe tool for more detail.

A bunch of the control panel options don't open when clicked either, but leave no error message.

I started searching around the web and found it's usually a fault with Microsoft Visual C++ Redistributable, and found it was recommended that I re/install 2005, 2008 and 2010.

I already have them all installed with both 32 and 64bit versions, and I've narrowed it down to the 2010 x86 redist. I downloaded it, and tried installing it over the top of the old one, but the installer gave me the same side-by-side config error as all other programs.

Event Viewer info for the installer gives me:

Activation context generation failed for "System Default Context". Dependent Assembly Micosoft.Windows.Common-Controls.Resources.language="*",processorArchitecture="x86",publicKeyToken="6595b64144ccf1df",type="win32",version="5.82.0.0" could not be found. Please use sxtrace.exe for detailed diagnosis.

I could potentially uninstall the 2010 x64 redist (it gets further than x86 at least), but upon trying to uninstall the 2010 x86 version I get the error:

Error 1719.The Windows Installer Service could not be accessed. This can occur if you are running Windows in safe mode, or if the Windows Installer is not correctly installed. Contact your support personnel for assistance.

I've tried system restore, which didn't work, and I've been searching for a solution for over 2 hours now and I'm pretty sure I just need to find some way of removing the faulty version of the C++ 2010 x86 redist, perhaps using a boot cd with an uninstaller.

Any ideas?

share|improve this question
    
sounds silly, but i solved that problem once simply resetting internet explorer to its defaults. tinyurl.com/pztksu2 –  Lorenzo Von Matterhorn Sep 14 '13 at 11:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.