Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just bought a new config ( ASUS p8z68-v lx, i5-2500k + ram and new graphic card ). Coming back and installing it in my old computer, I just saw that my DVD player was on IDE (yup…).

So, I needed to install windows 7 64bits from my usb key. Fine, I made my usb key bootable and copy the official DVD on it (the same version that was on my old computer), set BIOS to boot on it first and started the computer up.

It worked fine until it asks me for cd/dvd drivers (which is funny since, I do it via USB because I can't plug in my DVD player :D) I have 3 SATA HDD plugged in and that's it.

I made a small google search and found that it could be SATA or RAID drivers. Fine, I took another USB KEY and put all my motherboard drivers on it (from the CD sold with the MB) and none of those drivers seemed to work. I tried downloading new drivers from ASUS website and same effect.

Any idea but no "buy a new DVD player", I'm now broke for the month :) ?

share|improve this question

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

    
What device does it want drivers for exactly? There is nothing "special" about a driver cd. What exactly is wrong with a IDE DVD...the current Intel Series 6 motherboards to my knowlege all have an ide controller. –  Ramhound Mar 16 '12 at 18:02
    
It's not clear why you couldn't install from the DVD. Does your motherboard not have an IDE port? –  David Schwartz Mar 16 '12 at 18:05
    
@DavidSchwartz nope it does not have one usa.asus.com/Motherboards/Intel_Socket_1155/P8Z68V_LX/… ! –  HackToHell Mar 17 '12 at 5:04
    
@Ramhound no IDE port; so no old DVD player like mine, so no installation from DVD… It says "cd/dvd player driver is missing" with no more information… But I agree with you, there's nothing special about a cd driver… –  Shikiryu Mar 17 '12 at 8:47
    
It worked fine until it asks me - i dont get it - so did you install windows or not? The thing that you boot from usb have nothing to do with 'usb driver' for computer its just a boot media. Tell me exactly on which step of instalation you stack in. –  Pinger Mar 19 '12 at 16:17

13 Answers 13

up vote 15 down vote accepted
+50

You need USB 3.0 drivers to read installation media. Windows 7 is fine with AHCI.

share|improve this answer
3  
Why USB 3.0 drivers? Why AHCI? I don't get you, have you read anything in this question? –  Tom Wijsman Mar 20 '12 at 16:17
2  
because you have USB3.0 controller. Even it is electrically and programmatically compatible with USB2.0 windows will see USB device generation 3 and default driver will not install.... –  ZaB Mar 21 '12 at 13:38
    
But it booted from USB 3.0, so it should have access? –  Tom Wijsman Mar 21 '12 at 13:41
1  
I have read reports of USB 3.0 ports causing problems with W7 install due to missing 3.0 drivers, nothing I can verify though....h30434.www3.hp.com/t5/Other-Notebook-PC-Questions/… –  Moab Mar 25 '12 at 2:36
4  
Oddly (because it's been downvoted twice), this answer is the closest one that saved me :) Reading it made me realize that I may have been using one of the two USB3 port for the USB key having windows setup… I checked my MB manual and got it. I changed for a USB2 port and worked :) Anyway, I tried every drivers from my MB DVD before, including USB3… I guess installing an updated USB3 drivers (which I didn't think of) could have worked but found it easier to change to USB2 ;) . –  Shikiryu Mar 25 '12 at 15:45

Try this, ymmv.

Install from USB:

When Windows is asking for driver, just click Cancel. You will be brought back to the welcome screen. At the welcome screen, remove your USB drive, insert it back to DIFFERENT USB PORT. Click Install Now again. The installation process will be like usual.


Also, forget where I found this tidbit

"it was the SATA drivers for the MoBo"

"On another PC (obviously), I downloaded the latest Win7 drivers for my motherboard and put them on the USB stick that I was installing Win7 from (although this should probably work even if you install from DVD, just as long as you can get to them when you Browse from the error dialog). Once I got the error, I browsed to the files to install, but they still didn't show up. I unchecked the box for not displaying incompatible drivers and then they showed up. I selected the driver and hit Next and everything went smoothly after that."

"What drives me crazy is that the error message gets you looking for DVD drivers when it has nothing to do with that, plus Win7 doesn't even recognize the correct drivers as being compatible with the hardware!"

share|improve this answer
    
@Shikiryu: Does the above work? –  Tom Wijsman Mar 20 '12 at 16:14
1  
Unfortunately not. Cancel and redo just did the same thing twice (obviously). As I said, I already tried every SATA drivers from my MB DVD (transfered on another USB key) and from Internet... –  Shikiryu Mar 25 '12 at 15:39
    
Thanks, this worked for me! Crazy. –  qerub Dec 18 '12 at 17:52
    
Crazy sh*t Oo, works for me, too. :) –  CSchulz Apr 22 '13 at 16:29

The problem is a bit mysterious until you realize what's happening behind the scenes during a windows install. And, there is a workaround to allow you to use USB 3.0. One workaround is easier in the moment, the other requires a bit of work to setup, but will be easiest for future installs.

Introduction: What exactly is the problem

Here is a lengthy but casual description of the process, and why you can't complete the install:

  1. Bios starts the computer. Bios is software. It runs the POST - and loads basic support for various hardware devices. It is able to access the USB 3.0 ports, it finds the boot manager on the USB stick, and the bootmgr loads the windows 7 installation setup.

  2. Once the windows 7 setup exe loads - bios hands over control of the hardware. The bios access to hardware ends. Windows Setup must load it's own drivers to see the various hardware devices. I think this is called the Windows Pre-Installation Environment. It doesn't have USB 3.0 drivers. So no, just because you started with access doesn't mean you still should now. You don't.

    You may be aware that during this installation process, WinPE can see some hard disk controllers. Back in the day (win NT 4.0, 98 etc) it could see IDE controllers, but not SATA, or 3rd party, or many SCSI controllers. If you had a new motherboard, or add in card - you would have to press F6 and put a floppy disc in. WinPE would load drivers from the floppy, and then it could see the SATA controller, or scsi device, and installation to the disk on that new controller could then continue. The problem here is similar...

    Further Detail: While bios is accessing the USB 3.0 memory stick, WinPE creates a virtual hard drive, called, Drive X: and WinPE loads itself onto Drive X. Bios then hands over control, and WinPE examines drive X for inf files, to load any drivers it needs. For Windows 7, it has SATA, and USB 2.0 - but it does not have USB 3.0 drivers in it's arsenal. (Remember, Win98 didn't have USB 2.0 drivers either).

    So, why can't you continue? The problem is, only the WinPE environment and utilities (eg: the partitioning utility) are loaded onto Drive X. The actual windows 7 software is still stored as a package on the USB 3.0 memory stick - and now that bios has handed over hardware control to PE, you've lost access to it. We'll fix that Later...

    The last step in the process...

  3. NORMALLY, after WinPE unpackages the Win 7 files onto your hard drive, and reboots - (you might already realize this) - the Pre-Installation Environment evaporates. It was only stored on a virtual drive "X:" and since ram is erased on reboot - so was WinPE. So, you guessed it, Windows 7 would now be on your pc, and again, doesn't have access to USB 3.0.

Summary

So now, it should finally make sense, that Bios, Windows Preinstallation Environment, and Windows 7 are each their own operating systems, each more complex than the one before - but each needs it's own drivers to access devices.


The Solution:

It's actually pretty simple. You just need to add a driver to each OS. Bios has it's own. Windows PE and Windows 7 are stored as packages on the installation disc.

The long way around is to get a copy of your USB 3.0 drivers, and unpack the WinPE package, and if you want, unpack the Windows 7 package, stick the driver INF files into their driver caches, and repackage them, and put the updated package back on the install disc. Once that's done, you're good for any new installs you do. Someone else can tell you how to slipstream. It's a bit time consuming for a one time fix.

For a one off, it's a lot easier to do this.

Remember that a USB stick will only install Windows 7 if the stick is formatted NTFS before you copy your Win7 dvd to it. FAT wont work.

  1. Locate your USB 3.0 drivers for windows 7 (x32 or x64, I'm not sure how crucial that is). For myself, I used an Etron 168 and there was just one INF and it worked for x64. On a Win 7 x64 installation, there are both x32 and x64 drivers present, so start by matching the corresponding driver to the install you're working with. If that doesn't work, maybe try the other.
  2. Create a drivers folder on the USB stick, or on a second USB stick.
  3. Boot from the USB 3.0 port.

    (Misc notes: bios must be set to boot from a "USB-HDD" for this, and some mobo's are fussy - e.g.: Gigabyte - and some will default to the ssd or hdd anyway if it is bootable. )

    Win PE will load (very quickly, by the way), and will complain, The error is something about the CD/DVD drivers are needed. (note: CD/DVD, not a hard drive or scsi driver!)

  4. At this point, you have the option to Browse. Whichever USB stick you put the drivers onto - put it into a USB 2.0 port, and THEN browse. WinPE will autodetect the USB 2.0 stick, you can browse to the folder, and select OK. WinPE will load the USB 3.0 drivers.

    (REMEMBER - these drivers are for WinPE, and once it reboots, they will be lost.)

    Caveat: Because you've just accessed a USB 2.0 port, WinPE may want to locate any further files from that USB 2.0 port. After the USB 3.0 driver is loaded, REMOVE any stick from the USB 2.0 port, and ensure the USB 3.0 stick is in the USB 3.0 port. WinPE might error at this point, and it may appear to revert 1 step back. As long as the USB driver loaded, you will be able to move forward. It's for this reason, that if you do multiple installs, slipstreaming your driver into the WinPE package might be easier. Again, look elsewhere for how to do that.

  5. Ideally, once the driver loads, WinPE will move to the next step, and you can now start your install. Select or create the partition on your hard disk (or SSD), and start the install. With your USB 3.0 drivers working, WinPE will be able to locate the Windows 7 package on the USB 3.0 stick, and unpack it into the hard disk partition you selected.

    Note: It may not make sense, but WinPE could have seen, and allowed you to tailor the Hard disk or SSD, created and sized your partitions, and THEN complained it didn't have access to the Windows 7 package on the USB 3.0 stick - but for whatever reason, it stops things right up front, and asks for the CD/DVD driver (in this case, usb 3.0 driver).

    The install will be very quick from that point. For a build I just did, it unpacked Win7 onto a low end ssd in 4 minutes.

    At that point, it will advise it wants to restart the pc. Once the pc reboots, the install will continue exclusively using the files now on the hard disk /ssd.

  6. Therefore, remember to remove the USB stick during the reboot.

  7. Make sure bios is configured to boot from the C: drive (hard disk/ ssd) at this point.

    Windows 7 will configure itself, load any device drivers it can, and you'll be at the desktop in no time.

  8. Just remember you now need to put the memory stick in a USB 2.0 port and load the USB 3.0 drivers for Windows 7!

share|improve this answer
1  
As noted in this section of the FAQ, all of the user generated content on this site is licensed under CC BY-SA 3.0. Attribution is already required. –  JoshP Sep 24 '12 at 19:51
1  
I've made some major formatting changes to your answer to make it a bit more readable. Feel free to rollback/alter these changes as you see fit. –  KronoS Sep 27 '12 at 18:34
    
I am going to downvote for the simple fact the user wanted money for free information. –  Ramhound Oct 4 '12 at 17:58

OK, on short you must change the USB port. I nearly thought I wrecked a friends LAPTOP.

My problem was like this:

  • ASUS laptop
  • no physical DVD drive
  • WIN7 was asking for CD/DVD driver

As soon as I changed the USB port from 3.0 to another one (which I suppose was a 2.0 drive) it worked.

share|improve this answer
    
Exactly what I explained here . Thanks anyway :) –  Shikiryu Sep 24 '12 at 15:33
    
I had the exact same issue. After switching my USB installation media to a different (USB2.0 vs. USB3.0) port, worked fine. –  Rob3C Jan 26 '13 at 20:08
    
Had this issue reinstalling my Dell XPS13. Plugged boot flash drive into USB3 port. Plugging it into the USB2 port sorted it, no restart needed –  Dan J Jan 6 at 23:13

Normally you would need the AHCI/RAID drivers, wich can be made using this driver package: http://dlcdnet.asus.com/pub/ASUS/misc/sata/Intel_AHCI_RAID_V10501026_XPVistaWin7.zip

According to the description: "Make Intel AHCI/RAID Driver Disk". That is what setup needs to access the harddisks.

Officially the files in 'Intel_AHCI_RAID_V10501026_XPVistaWin7\Driver\64bit' should be what you need.

Alternatively you can recreate the USB stick using the official method that's suppored by Microsoft: http://www.microsoftstore.com/store/msstore/html/pbPage.Help_Win7_usbdvd_dwnTool

Good luck!

share|improve this answer
2  
That's everything I tried so far before posting here… without success. –  Shikiryu Mar 19 '12 at 20:42

Have you tried this: When setup asks for drivers close these two dialog windows until you are back on welcome screen and then change USB port (attach flash drive with Win7 setup to another port) and click "install now" again? It is much simpler.

share|improve this answer
    
This only works if you reconnect to a non 3.0 USB port. –  user148298 Jun 13 '13 at 23:03

I had this issue with an ASUS N56VZ laptop, which only has USB 3.0 ports (Intel chipset).

I went to ASUS's driver downloads for my laptop model, and found that 2 drivers in particular were necessary for success on my laptop: the Intel Chipset drivers (for USB 3.0 support), and the Intel RST drivers (Rapid Storage Technology). Note that you may not need the RST drivers if you have the RAID controller fully disabled (and only use AHCI mode).

Once I downloaded the drivers, I extracted the archives, and copied them both into the sources folder on the USB. Finally, I rebooted from USB stick in same USB port, and voila! Install as per the usual process.


P.S. It shouldn't make a difference, but just note that both my USB stick and ports are both USB 3.0.

share|improve this answer

Here's the easiest solution to the problem without the hassles of locating the correct driver. This issue happens only with the latest builds of windows 7 installer running from a USB drive connected to a USB 3.0 port (usually blue colored). Simply reconnect your USB drive to a non-3.0 port and restart the installer by clicking the close button on the setup window and trying again. Most newer motherboards have both ports.

share|improve this answer

Apparently Windows 7 has no built-in USB3 drivers (source) (unlike Win8 or 8.1) so after the control is passed from the BIOS (which does know its USB3 controller well enough) to Win7(PE), the OS looks for appropriate drivers to load for the controller onto its driver stack, but it fails to find any. So every port connected to a USB3 controller won't work without additional drivers. Also, I think all blue-ish ports are USB3.

Some BIOSes may allow downgrading the USB controller's mode for backwards compatibility, which can solve the problem in some cases, by forcing the controller to work in USB2 mode through the BIOS settings.


The seemingly easy solution is to find the appropriate drivers and supply them to Win7. They can usually be found somewhere around Support->Drivers-><OS>->USB in the motherboard manufacturer website, where <OS> is to be replaced with sth like "Windows 7 64-bit" in this case. It should be noted that the files may need to be unpacked beforehand, for the OS to recognize them. The folder containing the .inf (a.k.a. "setup information") file(s) for the appropriate architecture (amd64 in this case) needs to be made available to the OS.


In this particular case the following steps may work (links might become invalid, ...):

  1. Download this and unpack it,
  2. Copy the folder "Driver" to the USB memory,
  3. Once asked for the driver files, select the folder "Driver" or the file "asmthub3.inf" inside it.
share|improve this answer

Found another possibility in this thread :

I've since found the problem lies with the win 7 SP1 download. I've downloaded the original Win 7 non SP1 file from Technet downloads and it installs ok, it doesn't ask for a CD/DVD driver...

share|improve this answer
1  
Thanks, but I have an official Windows 7 64bits DVD. I didn't download it ; no SP1 here then ;-) –  Shikiryu Mar 19 '12 at 20:44

I had this problem as well a while back and if I recall correctly I simply tried another USB-port and it worked. It is also very important that you make the Windows 7 USB installer following these steps: http://www.intowindows.com/how-to-install-windows-7vista-from-usb-drive-detailed-100-working-guide/

(I'm not promoting any site here, there are several guides like this one and I just picked one of many)

share|improve this answer
    
See my answer. It has to be a 2.0 port. –  user148298 Jun 13 '13 at 23:02

I understand that my last answer was deleted because it was commentary in nature, but the reason I posted it was because I wanted to let others know what process I was going through in order to encounter the same problem. Suffice to say, I created two USB keys through different methods and neither worked. I burned the ISO from one of the keys to a DVD and was able to install just fine with it to the computer. Besides the solutions that I see listed above about the key being in a USB 3 slot and it not having a driver for it, I seen one more thing that might work, I will try it tonight and then update you to see if it works.

Since Windows 7 won't load unsigned drivers by default, you need to press F8 when the DVD PE-OS is booting and select Advanced Boot Options, choose Disable Driver Signature Enforcement. This should solve the issue if the other method didn't work.

share|improve this answer
    
This sounds more like a comment rather than an answer. –  Darius Oct 4 '12 at 17:47
    
Until I am able to try the F8 workaround myself, I would say it's more of a suggestion. I will update once I am able to try it out and confirm that it works. –  Eric Oct 4 '12 at 21:16

Make sure your USB is not in a USB 3.0 port. Disable XHCI Pre-Boot Mode in BIOS. This will disable the USB 3.0 port so the Windows Installation doesn't see it, and therefore doesn't require drivers for it.

share|improve this answer

protected by Community Jul 16 '13 at 18:07

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.