Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

It appears that I have autopushd turned on (I know I didn't turn it on) and it is rather annoying because I prefer to pick and choose when to use the directory stack. How can I turn off autopushd?

I have looked in ~/.zshrc and ~/.oh-my-zsh/oh-my-zsh.sh but couldn't find anything.

I am using oh-my-zsh on Mac OSX Lion.

share|improve this question
add comment

2 Answers

up vote 5 down vote accepted

It's set in ~/.oh-my-zsh/lib/directories.zsh. I would either comment it out there, or unset the options in your .zshrc after loading oh-my-zsh.

share|improve this answer
add comment

Maybe you have the dirpersistplugin from oh-my-zsh loaded or perhaps you are sourcing some kind of $ZDOTDIR/z.* at startup. Have a look at the manpage for startup files.

Just type unsetopt autopushd to disable the feature for the current session and setoptto verify that it is really unloaded.

To find the source of the problem I would run zsh -x 2> log, exit immediately and inspect the context of every pushd in the log...

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.