Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a pair of private and public keys. The public key is on my server and I have my private key on my local disk. The file's permissions were changed with the command:

chmod 600 private_key

Now I try to login into my server with the command:

ssh -i path_to_the_private_key username@servername

My Mac shows me a dialog box and asks me for the password. I enter the password but my Mac says the password is incorrect.

When I use the same private key to log to the same server with the use of putty and the same password everything works great.

Any hints?

The out put from the ssh command:

OpenSSH_5.2p1, OpenSSL 0.9.8r 8 Feb 2011
debug1: Reading configuration data /etc/ssh_config
debug1: Connecting to servername [...] port 22.
debug1: Connection established.
debug1: identity file private_key_su.ppk type -1
debug1: Remote protocol version 2.0, remote software version OpenSSH_5.8p1 Debian-7ubuntu1
debug1: match: OpenSSH_5.8p1 Debian-7ubuntu1 pat OpenSSH*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_5.2
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-ctr hmac-md5 none
debug1: kex: client->server aes128-ctr hmac-md5 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
debug1: Host 'servername' is known and matches the RSA host key.
debug1: Found key in path:4
debug1: ssh_rsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey
debug1: Next authentication method: publickey
debug1: Trying private key: private_key_su.ppk
debug1: PEM_read_PrivateKey failed
debug1: read PEM private key done: type <unknown>
debug1: PEM_read_PrivateKey failed
debug1: read PEM private key done: type <unknown>
debug1: PEM_read_PrivateKey failed
debug1: read PEM private key done: type <unknown>
debug1: PEM_read_PrivateKey failed
debug1: read PEM private key done: type <unknown>
debug1: PEM_read_PrivateKey failed
debug1: read PEM private key done: type <unknown>
debug1: No more authentication methods to try.
Permission denied (publickey).
share|improve this question
    
If your Mac asks you for a password, it's your user account password, not the SSH pass. –  slhck Mar 17 '12 at 13:06
    
No it's not. The dialog box says "Enter your password for the SSH key name_of_the_key_file". Just to be sure I had entered my account password but it did not work too. –  Jakub Mar 17 '12 at 13:16

2 Answers 2

I believe OpenSSH and Putty use different formats for the private key file. You can load the private key into PuttyGen and convert it to OpenSSH format

PuttyGen Menu

share|improve this answer
    
The thing is that I've created the key with the ssh-keygen tool on a Linux machine, so it's not the case. –  Jakub Mar 18 '12 at 11:49
    
This answer solved my same problem. –  Tomanow Aug 19 '13 at 17:02

I had this same problem only difference is my private key file was pem format; yours is ppk. I resolved this by opening the private key file in TextWrangler and changed the encoding from "Unicode (UTF-8, with BOM)" to "Unicode (UTF-8)" and I changed the line breaks from "Classic Mac (CR)" to "Windows (CRLF)." I know that seems backwards but it is the only change I made and it worked.

The file settings are at the bottom of the TextWrangler window.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.