Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have Google searched for an hour now and I am confounded. I am using InnoSetup to install a .NET Winforms application that creates directories and folders on the fly. (I have set the folder options to display hidden files, folders...) Although the files that are added to "created" folders appear within the application, they do not show when using Windows Explorer or even when issuing a Dir from a command prompt. I have also modified the application to display (and delete) the contents of these (seemingly imaginary) folders, so I am sure they exist.

What am I missing?

share|improve this question
2  
If you have 64 bit Windows 7, look in the C:\Program Files (x86) folder too. –  Andrew Lambert Mar 18 '12 at 0:16

3 Answers 3

up vote 4 down vote accepted

The files probably ended up in %LOCALAPPDATA%\VirtualStore. I had a similar problem with some programs that saved in a protected (Program Files) folder without elevating properly (UAC), in Windows Vista.

See here for further details.

According to that site, there should be a Compatibility files option in Windows Explorer. I've personally never noticed that before now, but it does appear and it does work.

Screenshot of Compatibility files
(Image sourced from linked site)

share|improve this answer
    
Bingo! Thanks Bob. –  ron tornambe Mar 18 '12 at 4:07

Check if the file operation have been redirected. Keep in mind that it takes admin permissions to write to the Program Files folder.

share|improve this answer
    
Great point - I'll have to make some amends. –  ron tornambe Mar 18 '12 at 1:18

You wrote:

I have set the folder options to display hidden files, folders...

There is 2 kind of "hidden" files ans folders: hidden and "super hidden" such as the system protected files.

It's possible to create such "super hidden" file with the command:

attrib +s +h filepath

In the folder options you may uncheck the option "hide protected operating system files (recommended)" to see them.

The files you're looking for may have theses "super hidden" attributes...

Hope this help. Let us know.

share|improve this answer
    
It turns out that .NET (Framework 4) applications running on Windows 7 (and presumably Vista) automatically redirect operations (FileCopy, Delete, etc.) specifying the d:/Program Files folder to a virtual user location (in my case C:\Users\Ron\AppData\Local\VirtualStore\Program Files). –  ron tornambe Mar 18 '12 at 4:06
    
Actually, it's the OS itself that does this, not the .NET framework. See the "for further details" link in Bob's answer. –  Wayne Johnston Mar 19 '12 at 0:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.