Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I like using a single Sublime Text 2 window with multiple tabs. Currently, when I click on files in Finder that are openable via ST2, they open in separate ST2 windows. How do I force ST2 to open tabs in a single ST2 window for new files?

share|improve this question
add comment

2 Answers

up vote 33 down vote accepted

Since you're on OSX, this is a feature that is enabled by default. You will need to go to the default settings and scroll down to like 280. Change this value to false. Do not delete the comma though.

enter image description here

enter image description here

share|improve this answer
    
That worked. Thanks. –  Sajee Mar 18 '12 at 18:02
8  
You should always copy the settings you want to change in the User settings and change its value there. If you update Sublime Text, the default settings might get overwritten. –  mbillard Apr 23 '12 at 13:47
    
are these prefs for Sublime or for Finder ? –  amphibient Aug 14 '13 at 19:46
    
They are for Sublime Text –  kobaltz Aug 14 '13 at 20:13
    
It did not work for me. I changed the setting, closed the existing instance of the app, opened file1 with Sublime, that started a new instance (with hopefully the new setting taken effect), went to open file2 ... same thing again, new instance of Sublime –  amphibient Aug 14 '13 at 20:49
show 1 more comment

I opened Sublime Text2-->Preferences-->Settings User and changed it to have the below contents

// Settings in here override those in "Default/Preferences.sublime-settings", and
// are overridden in turn by file type specific settings.
{
    // OS X only: When files are opened from finder, or by dragging onto the
    // dock icon, this controls if a new window is created or not.
    "open_files_in_new_window": false
}
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.