Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have Ubuntu 11.10 in Virtual Box installed on Windows Vista. I am having a Broadband(PPPoE) internet connection. I would like to use my internet connection inside Virtual Box in Ubuntu. I tried with NAT but it couldn't connect. Then I tried Bridged Network, but still it is not connecting!!

Where am I going wrong?

share|improve this question
    
Did you select the correct adapter? –  Dr Kitty Mar 18 '12 at 19:12
    
Select NAT and in Ubuntu, connect to wired network, that should do the trick. –  HackToHell Mar 19 '12 at 4:17
    
@TheElectricMuffin yes!! I selected the correct adapter. –  Ashutosh Dave Mar 19 '12 at 7:33
    
@HackToHell I selected NAT but its not working!! –  Ashutosh Dave Mar 19 '12 at 7:33
    
Although this doesn't help for existing Virtual Boxes, I can recommend Vagrant for any new boxes you might want to create. It's essentially a wrapper for Virtual Box that allows you to easily customise these sorts of things. –  DanielM Apr 23 at 14:30

4 Answers 4

I use a PFsense router/firewall virtual machine with two adapters, one set to bridged for the WAN and the other set to the Internal (to VirtualBox) network. Then place the Ubuntu VM on the internal network, with the PFSense box set to provide a a IP address via DHCP. This video provides a guide (though it's oriented to setting up a Windows based network): http://pc-addicts.com/how-to-install-pfsense-in-virtualbox/

share|improve this answer

You have to make sure that in the Network tab these two boxes are checked:

enter image description here

Then from inside the virtualized Ubuntu, you must connect to wired network, it should work.
You need to have installed the Guest Additions for this to work properly.

share|improve this answer

Please see this link http://www.cyberciti.biz/faq/setting-up-an-network-interfaces-file/

I hope entering the following information in /etc/network/interfaces file will help

auto eth0<br>
iface eth0 inet dhcp
share|improve this answer

Make sure you install the Virtual box Guest Software in Ubuntu. Then use NAT on the Virtualbox. Since your Ubuntu version is older it may not have native support for the network adapter Virtualbox offers.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.