Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a PowerBook G4. OS-X 10.5.

Recently is was running very slow and I found it only had about 3 GB free.

I set to and free'd up 26 GB on the 93 GB drive.

Finder, however reports about 15 GB used and Disk Inventory X says about 20 GB

System Profiler and Disk Utility both report 66 GB used.

Where is my missing disk space?

Update: I ran fsck_hfs -fy /dev/disk0s3 (in my case) and it said I had to 'reboot now'.

I shutdown and restarted. Normally I get an Apple Logo. This time 2 (I think) smaller square icons appeared - 1 looked like a folder with a '?' in it, the next looked like a finder icon on a folder icon. I have never seen these before. After booting, finder reports 28 GB free - up from 26 GB. I ran command again - this time it report a few errors and I have to reboot again.

This shows usage:

delta-2:~ phil$ df  
Filesystem    512-blocks      Used Available Capacity  Mounted on  
/dev/disk0s3   195109344 134777912  59819432    70%    /  
devfs                210       210         0   100%    /dev  
fdesc                  2         2         0   100%    /dev  
map -hosts             0         0         0   100%    /net  
map auto_home          0         0         0   100%    /home  
delta-2:~ phil$  

sudo du -c /  
 134001096  /  
134001096   total  

Disk Inventory X (trust me) shows Macintosh HD (17.5GB) in window title which is used physical capacity. used logical capacity is 16.8 GB.

DIX shows directories from largest to smallest: Largest is Library at 4.4 GB. Only top 6 folders are larger than 1 GB. These sum to 16.9 GB - matching what finder reports.


I suspect a bug with Finder (or an OS call that both Finder and DIX use). Both Finder and DIX under-reported used capacity initially. Now I have deleted a huge number of files, both Finder and DIX now seem to be reporting used capacity correctly (or at least more reasonably).

share|improve this question
You are consistently using the same GB definition, right? Newer versions of OS X use 10^3 instead of 2^10, i.e. actual SI prefixes. – Daniel Beck Mar 19 '12 at 5:24
To clarify, Finder, however reports about 15 GB used and Disk Inventory X says about 20 GB — these tools report the free disk space? – Daniel Beck Mar 19 '12 at 5:25
Well, I'm reporting values that I assume are GiBs - but the amount 'missing' is too much for an error in units to explain I think. – philcolbourn Mar 19 '12 at 5:37
Finder can be told to report used as well View-Show View Options--Calculate all sizes. – philcolbourn Mar 19 '12 at 5:39
Have you compared your selection for which you calculate all sizes to the output of Disk Inventory X for scanning the whole drive? There are tons of directories in the disk's root folder. In fact, if you're using Disk Inventory X, you should already know where all your disk space is. Please provide its output to show that it doesn't add up to total disk capacity. Or better yet, use a tool that can run with administrator privileges to index space used by files in directories inaccessible to your user account, like Daisy Disk (Scan as Administrator). – Daniel Beck Mar 19 '12 at 5:44

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.