Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm currently running very large network simulations for my PhD research, for which I need lots of RAM. I have a Core i7 2600K processor with a Gigabyte GA-Z68AP-D3 motherboard, running Windows 7 professional 64bit.

I bought the system with 8GB (2x4GB) DDR3 1600 MHz Corsair Vengeance RAM and the system ran like a dream. I'm planning to upscale my simulations so I removed the 2x4GB RAM and installed 4x8GB DDR 1600 MHz Corsair Vengeance RAM.

When I rebooted the system, boot time was much longer than usual (10 mins just to get to login screen). After logging in, the whole system was unresponsive. I tried playing some games (Bioshock 2), but it was unplayable. I've not had this problem before and I have an ATI Radeon HD 5850 graphics card, so that's not the problem. The only thing that's changed is the RAM.

I've looked through the specifications of Windows, my motherboard and my CPU and they all state that 32GB of RAM is supported. Does anyone have an idea of what's going on? Any help would be greatly appreciated.

More info: Thanks for all the answers guys. Will try the proposed solutions and report back tonight. To answer some of the questions:

  • I did remove half the RAM, so now running on 16GB and this fixed everything. This is what I'm running now, but I still need the extra RAM.
  • Windows detects 32GB of RAM and shows that's it's all addressable under system information.
  • I've booted my Linux virtual machine, which was as slow, but this could just be because of the Windows host. I'll try to find and boot from a live CD.
  • All my memory modules are 1600 MHz, but the timings on the 8 GB modules are somewhat slower (10, instead of 9).
  • I've rebooted the system multiple times, also thinking Windows is just "adjusting", but the problem remains.

Testing method: I've now tested my slots and modules in the following way to try and quickly rule out bad slots or modules:

  1. Starting with four 8GB modules. The system is extremely slow.
  2. I removed two of the four 8GB modules. The system worked fine and we know those two modules are fine.
  3. I added my "old" 2x4GB modules back into the system. The system detected 24GB RAM and everything worked fine, so we know the RAM slots all work.
  4. I removed all modules and added the other two untested 8GB modules back into the system. The system worked fine!
  5. Again adding all four 8GB modules. The system experienced a factor 40 or so slow down.

Doing this I can only conclude that all my modules and slots are fine and that there's some other hardware or software constraint that preventing me from getting all my RAM working.

Eventual solution: As some of the users have stated in this thread, the solution was to turn my on-board graphics card to always be on and to increase the on-board graphics card memory. The system works fine now. Thanks everyone!

share|improve this question
    
Have you put the old RAM back in to double check this? –  ChrisF Mar 19 '12 at 10:07
7  
what happens if you boot from a linux live cd? –  artistoex Mar 19 '12 at 10:40
1  
having the same speed (1600mhz) doesn't mean they have the same timing : en.wikipedia.org/wiki/DDR3_SDRAM , in the Modules section. –  woliveirajr Mar 19 '12 at 16:37
1  
@John Gilmore If this isn't solved yet, what's the condition of the HDD? Did the slowdown go away after a while? I suspect that it could be windows rebuilding swap file in order to have it big enough for the 32 GiB of RAM. In such setup, the swap file might be as large as 64 GiB. –  AndrejaKo Apr 11 '12 at 6:40
1  
You obviously don't have enough, try adding some more –  ekaj Dec 6 '12 at 2:18
show 4 more comments

10 Answers

up vote 9 down vote accepted

When we experienced this issue, we fixed it by enabling the on-board VGA (set to on all the time, not just when a graphics card is not present) and increasing the onboard graphics RAM to the max (400+ MB) in the advanced section of the BIOS. After this, the computer started up in under 20 secs.

share|improve this answer
    
I think I'll try this. Will report back if it works. Thanks for the suggestion. –  John Gilmore Aug 30 '12 at 17:13
    
This solution worked for me. Thanks for posting it! –  John Gilmore Dec 16 '12 at 8:59
7  
What could be the technical reason this is the solution? –  deed02392 May 16 '13 at 12:35
    
But then, you can't use your graphics card? –  Annonomus Penguin Aug 4 '13 at 1:18
add comment

It sounds like faulty RAM to me. The motherboard might have adjusted the speed down until it worked.

memtest86+ is a good bootCD to run a test with:

http://www.memtest.org/#downiso

And CPUZ gives excellent information on the current state of your hardware:

http://www.cpuid.com/softwares/cpu-z.html

Definitely look at the timings on each RAM module. Whilst the speed my match if their timings are miss-matched you would get a slow down.

share|improve this answer
5  
Testing it is not a bad idea, but probably isn't the problem. Even if the motherboard were running the ram at a slower speed, it wouldn't make THAT much difference. –  psusi Mar 19 '12 at 17:47
add comment

I have seen this issue in the past and the problem was quite elusive:

Memory modules have a chip on them called the SPD which identifies to the motherboard operating parameters. The sticks of RAM I'd installed needed to run with about 2.1 V but the SPD chip was identifying them as a previous model which ran on just 1.8 V.

Hence my motherboard powered them with insufficient voltage. I was told by the manufacturer that this shouldn't be an issue, however the additional current the modules were pulling because of the lower voltage and the fact I had four of them in apparently a 'not very good motherboard' meant running with four caused poor performance and random BSOD's.

Overriding the voltage of the modules to what the manufacturer specified in the tech spec resolved all these issues.

Perhaps try identifying the SPD information from a diagnostics program like Piriform's Speccy and then comparing this to the given tech spec on the manufacturers website. Set the modules to these values manually to check it fixed it.

share|improve this answer
add comment

Turn on on-board graphics and allocate as much RAM as possible to it.

I submitted a support request with Gigabyte, this was their response:

It is known issue that using 32GB memory will require onboard vga shared memory to be set to 256MB. If with 32GB RAM the system gets poor performance then please set Onboard VGA to “Enable If No Ext PEG”

Thanks

Worked for me certainly:

MaxxMEM before and after MaxxMEM before and after

3DMark before and after 3DMark before and after

System config:

  • Windows 7 64-bit Ultimate

  • Gigabyte GA-Z68AP-D3 Z68

  • 32GB Vengeance 1600MHz (4x 8GB sticks)

  • Intel Core i5 2400 3.1GHz

  • 120GB Agility 3 SSD

share|improve this answer
add comment

You just install RAM of 4GB and test one by one in your board and check the speed of your computer. The problem may be in your new RAM or your motherboard-RAM slot. So try this one by one. I hope you will get solution.

share|improve this answer
add comment

Maybe thet 4 DIMMs modules are to much for the 2600k memory controller. The fact that the motherboard say that 32Gb are supported simply mean that the motherboard have the wires to connect the memory to the cpu, but the memory controller is inside the cpu. So if the memory dimms require to much current, maybe that the memory controller inside the 2600k is unable to drive 4x8Gb dimms properly.

Things I would try:

  1. Try 1 single 8Gb dimm in each dimm slot on the motherboard (1, 2, 3, 4) to check if all dimm slots works properly (if it's supposed to works, check on the mobo manual, maybe you can on install a single dimm in slot 1 or 3, but not 2 or 4...)
  2. Try the 4 dimms, one at time, on the first dimm slot; to check if every 8gb dimm works properly
  3. Try 2x8Gb dimm + 2x4Gb dimm, just to check if you can have a 24Gb system working properly (24Gb is better than 16Gb :-))
  4. Try to reinstall 32Gb of ram, and the slow it down using the BIOS setting, because a memory with a lower clock will require less current, and maybe it will works correctly with the memory controller of the 2600k
  5. Check the bios setting related to RAM, an see if there is something useful that can be tweaked
  6. If you have a lot of time, use http://www.memtest.org (as already suggested) to
    1. check if each dimm alone work properly
    2. what happen when you install 16Gb vs 32Gb (does the memory test run slower? does it find any error?)
share|improve this answer
    
The datasheet of the Intel CPU I'm using, also states that it can run 32GB RAM. –  John Gilmore Mar 29 '12 at 8:04
    
That's true, I've looked at the 2600K datasheet too, it say it can run 32Gb of ram; but it doesn't say it will run any combination of any type of 32gb ram on any motherboard. I still think it can be a memory controller power/compatibility issue... but without a working "reference" ram/cpu/mobo/system there is no simple way to check it :-| –  Max Mar 29 '12 at 12:21
add comment

If all the previously suggested answers did not work for you, flashing your BIOS with a newer firmware is a good option. Some motherboards have trouble with large amounts of RAM and newer BIOS firmwares are typically introduced by mobo manufacturers to resolve RAM incompatibility issues as well as performance issues with a large amount of RAM.

Here is an example from a GIGABYTE motherboard BIOS releases page (look at release description column): http://www.gigabyte.com/products/product-page.aspx?pid=3305&dl=1#bios

share|improve this answer
add comment

I solve the problem using this computer :

  • i5 2500k
  • GA-Z68AP-D3 rev2.0
  • Corsair 1600MHz
  • Sapphire 7970 OC

I updated an Award BIOS (FD) to the EFI bios (UE5). Work like a charm. EFI bios are beta however so watch out.

share|improve this answer
    
You solved an entirely different problem. –  Ramhound Oct 2 '12 at 16:51
    
@Ramhound No. 16GB was working fine. 32GB was horrible. Computer was slow (~30 seconds to open) instead of 5-6 seconds. Someone said to always enable the internal GPU, didn't work. I tested all BIOS version (FA, FB, FC, FD) and didn't work either. I ended up by upgrading to the EFI Bios and it worked like a charm. –  David Bélanger Oct 2 '12 at 17:52
add comment

I have a similar situation - and I'm not running Windows. I can run all day with 16GB at "normal" memory settings - the X.M.P. profile (doesn't matter which memory modules I install). But when I install 32GB if I don't lower the memory speed (less than the X.M.P. specs) in the BIOS I will get memory errors. The slightly lower speeds are not crucial but I need the extra memory for running virtual machines. Download the System Rescue CD and use its memory test to find a working configuration.

share|improve this answer
add comment

You have to upgrade to either the Professional or Ultimate edition of Windows.

I had this problem when I increased my RAM to 24 GB. I had to upgrade to Professional and it worked fine.

enter image description here

Here's a link that will tell you which version to use based on it's memory limits:

share|improve this answer
7  
The user already indicated he is using Windows 7 Professional. So you either didn't read his question or you simply ignored that part of the question. –  Ramhound Aug 14 '12 at 19:55
add comment

protected by Community Dec 12 '12 at 9:30

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.