Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've set up Postfix on a VPS running Centos 6, and I can access webmail using Squirrel Mail fine. But when I send or receive emails from my Gmail and other personal account I don't receive them on the VPS. I get no bounce back messages either.

What could be the cause?

EDIT
I had an issue before with MX records and DNS, and these were resolved, hence why I didn't supply details of them.

Here are the records I have for my server:

NS                          ns1.6sync.net.  
NS                          ns2.6sync.net.  
NS                          ns3.6sync.net.  
ftp             A           80.77.87.21 
gravex.co.uk.   A           80.77.87.21 
gravex.co.uk.   MX   10     mail.gravex.co.uk.  
mail            A           80.77.87.21 
setanta         A           80.77.87.21 
www             A           80.77.87.21

I'm 99% sure these records are correct, as when I tried to send emails before I would get a DNS error bounce back. I don't get these any more.

share|improve this question
add comment

3 Answers

up vote 1 down vote accepted

There are a number of things that need to be in place, but off the top of my head.

1) MX Records pointing to the proper IP.
2) Postfix needs to be defined to receive mail for the correct domains
3) Firewalls need to be configured
4) SFP Records may need to be setup

I'm going to assume from the lack of data in your post this is the first time you've done this, so I'll try and find you a primer: http://rimuhosting.com/support/settingupemail.jsp?mta=postfix&t=dns

Hopefully this can get you started.

share|improve this answer
    
Thank you for that link, I'll go through it later. I had followed a tutorial to set up ISPConfig 3 on the server. But the Postfix bit was quite vauge to be honest. –  mickburkejnr Mar 19 '12 at 16:01
    
HELO mail.gravex.co.uk 250 setanta.gravex.co.uk MAIL FROM:<jidar@removed.local> 250 2.1.0 Ok RCPT TO:<admin@gravex.co.uk> 550 5.1.1 <admin@gravex.co.uk>: Recipient address rejected: User unknown in virtual mailbox table, this looks good so far. Run the same commands via telnet mail.gravex.co.uk 25 for a known user and report the results. –  jidar Mar 19 '12 at 16:08
    
Sorry for sounding thick, but I've never used that HELO command? What do I do with it? –  mickburkejnr Mar 19 '12 at 16:24
    
Few things, but in this case it's telling the mail server you're connecting to who you're connecting too. As a mail server can run multiple domains, you're telling him, "Hey mail.gravex.co.uk, Let's SMTP together." –  jidar Mar 19 '12 at 17:12
    
That makes sense. I followed all of the steps you used and they all came back with 2.1.0 Ok. –  mickburkejnr Mar 19 '12 at 21:35
show 1 more comment

You do not metion DNS MX records. thus lack of one is a source of your problem.

share|improve this answer
add comment

I had a problem receiving email, and maillog complained "AAAA record not found" even though I had IPV6 disabled.

I found the problem that though my mail server (postfix) was complaining about the AAAA record not found, it was actually caused by the mail server's /etc/hosts file. The mail server name was defined twice, once as localhost (which was correct) and again using the public facing IPV4 address (this was causing the bounce).

I removed the second entry associated with the public IP, the complaint about AAAA record missing went away and mail was able to be received. I suspect had this second /etc/hosts entry been a valid IPV6 address, the two entries would be valid. So, the error message wasn't completely inaccurate. But, because IPV6 was disabled, the error message was a bit confusing in my case.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.