Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using Ubuntu 11.10 and get the following error when using the terminal:

lee@theia:~$ regedit/home/lee/desktop/Direct3D.reg
bash: regedit/home/lee/desktop/Direct3D.reg: No such file or directory
share|improve this question
1  
Did you enter the command yourself? Or is that what shows up every time you open the terminal? It looks like you are trying to load a .reg file, which is for the Microsoft Windows Registry, unrelated to Linux. Can you edit your question to provide more details? –  iglvzx Mar 19 '12 at 22:40
3  
You'll probably get more useful answers if you describe the context in which you got this message or what you were trying to do. –  David Schwartz Mar 19 '12 at 22:47
1  
The error message is sort of self explanatory I thought –  Simon Sheehan Mar 19 '12 at 22:53
add comment

closed as not a real question by iglvzx, Simon Sheehan, slhck, Nifle, Shinrai Mar 20 '12 at 14:19

It's difficult to tell what is being asked here. This question is ambiguous, vague, incomplete, overly broad, or rhetorical and cannot be reasonably answered in its current form. For help clarifying this question so that it can be reopened, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

2 Answers

It means that the string you entered, regedit/home/lee/desktop/Direct3D.reg is not a shell internal. So the shell tried to process it as a command, but was unable to find any command with that name. Because the string contains a /, the shell tried to match the part before the slash to a directory and was unable to find such a directory.

share|improve this answer
add comment

It seems like you wanted to do regedit /home/lee/desktop/Direct3D.reg (see the space after regedit command).

That way, the line resembles line that you would use on Windows to import entries to Windows registry. But there's no such thing as Windows registry (and no such thing as Direct3D) in Ubuntu, which (no offense meant) qualifies such attempt for an IT joke.

(Also paths are case-sesitive on Ubuntu and I believe that default desktop folder is named Desktop, not desktop.)

share|improve this answer
    
Unrelated: You might very well be partially wrong. (source) –  Eroen Mar 19 '12 at 23:01
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.