Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am running a debian machine with ISPConfig 3.0.4.3. Yesterday I purchased a RapidSSL wildcard certficate and want to make sure my IPSConfig always loads the admin.mydomain.net url. Even if the user connects to the IP, I want the IP to re-route to the page.

How can I do this? I added the following in the top of my 000-ispconfig.vhost file, but I got the ssl_error_rx_record_too_long error.

What I added:

<VirtualHost XXX.XXX.XXX.XXX:443>
        ServerName admin.mydomain.net
        ServerAlias mydomain.net
        Redirect permanent / https://admin.mydomain.net
</VirtualHost>

How can I make a https connection on my IP adress redirect the user to admin.mydomain.net?

share|improve this question
    
Have you tried using *:443 instead of the ip? – Lucas Kauffman Mar 20 '12 at 9:30
    
I do not want every SSL connection to redirect to this page. Only when the IP address is accessed directly I want the user to be redirected. – Paul Peelen Mar 20 '12 at 9:32
    
Is mod_ssl enabled and properly working for other pages? – Lucas Kauffman Mar 20 '12 at 9:41
    
Yes. Mod_ssl is enabled and SSL is working on the server. See bit.ly/GBKsJP – Paul Peelen Mar 20 '12 at 9:53

You must log in to answer this question.

Browse other questions tagged .