Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've set up vnc4server on an ubuntu server, and installed xfce4. Even though the vnc server starts (with or without a few X11 warnings), it won't let me connect!

Is there a setting somewhere that prevents anyone from logging in?

Here's the log file:


Xvnc Free Edition 4.1.1 - built Feb  5 2012 20:04:02
Copyright (C) 2002-2005 RealVNC Ltd.
See http://www.realvnc.com for information on VNC.
Underlying X server release 40300000, The XFree86 Project, Inc


Tue Mar 20 13:23:20 2012
 vncext:      VNC extension running!
 vncext:      Listening for VNC connections on port 5900
 vncext:      created VNC server for screen 0
error opening security policy file /etc/X11/xserver/SecurityPolicy
Could not init font path element /usr/X11R6/lib/X11/fonts/Type1/, removing from list!
Could not init font path element /usr/X11R6/lib/X11/fonts/Speedo/, removing from list!
Could not init font path element /usr/X11R6/lib/X11/fonts/misc/, removing from list!
Could not init font path element /usr/X11R6/lib/X11/fonts/75dpi/, removing from list!
Could not init font path element /usr/X11R6/lib/X11/fonts/100dpi/, removing from list!
Could not init font path element /usr/share/fonts/X11/Type1/, removing from list!
Could not init font path element /usr/share/fonts/X11/75dpi/, removing from list!
Could not init font path element /usr/share/fonts/X11/100dpi/, removing from list!

xfwm4-WARNING **: The display does not support the XRender extension.

xfwm4-WARNING **: The display does not support the XComposite extension.

xfwm4-WARNING **: The display does not support the XDamage extension.

xfwm4-WARNING **: The display does not support the XFixes extension.

xfwm4-WARNING **: Compositing manager disabled.

GLib-GObject-WARNING **: /build/buildd/glib2.0-2.31.20/./gobject/gvalue.c:185: cannot initialize GValue with type `gint', the value has already been initialized as `gint'

GLib-WARNING **: (/build/buildd/glib2.0-2.31.20/./glib/gerror.c:390):g_error_new_valist: runtime check failed: (domain != 0)

xfwm4-WARNING **: Failed to connect to session manager: Kon geen verbinding maken met de sessiebeheerder: SESSION_MANAGER environment variable not defined

And ps is letting me know it's still running:

17341 pts/3    S      0:00 Xvnc4 :0 -desktop barabas:0 (skerit) -auth /home/skerit/.Xauthority -geometry 1024x768 -depth 16 -rfbwait 30000 -rfbauth /home/skerit/.vnc/passwd
share|improve this question

1 Answer 1

What a silly cause! The tutorial I followed told me to start it like this:

su skerit -c 'vnc4server :0 -geometry 1024x768 --localhost'

Removing the localhost part solved it.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.