Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

On my Windows 7 machine, when I make a copy (Ctrl+C, Ctrl+V) of a file in the same folder I get the new file created with " - Copy" added to the file name:

1st copy: "foo.txt" -> "foo - Copy.txt".
2nd copy and so on: "foo.txt" -> "foo - Copy (2).txt".

Is there a way to change this naming pattern?
Particularly I'm interested in changing the naming from " - Copy (index)" to "_index", so that the files would be named foo_1.txt, foo_2.txt and so on.

I know there are 3rd party file managers that can do this, but I would like to know if there is a way to change this naming pattern in explorer.

Thank you!

share|improve this question

1 Answer 1

I researched and find this answer :

With Supercopier, use Ctrl + click/drag to copy files.

SuperCopier Website

In Supercopier's Confuguration settings, go to "Copies & moves behaviour", and in "Old file renaming pattern" type "" and in "New file renaming pattern" type "Copy of ".

If you use just right-click and drag to make file copies, the context menu will give you the option to use Supercopier, but the default option is Windows' own copying.

However, if you use Ctrl + click/drag, it uses Supercopier to copy, and the copy is named according to your preference. If a file is copied using Ctrl + click/drag to another directory, the renaming pattern is not used -- the customised renaming is used only on files copied to the same directory.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.