Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When trying to veiw a number of different websites in IE8, I get the following error message:

HTML Parsing Error: Unable to modify the parent container element
                    before the child element is closed (KB927917)

On investigating the error message, it appears the script is trying to modify parts of the page before it is fully loaded.

Is there a setting in IE8 I can change to prevent scripts from running until the page is fully loaded?

EDIT: The sites in question used to work just fine, until I had to re-install IE8 for a seperate issue. Then they stopped working.

share|improve this question
    
So, have you actually checked out MS' KB927917 yet? –  techie007 Mar 20 '12 at 20:42
    
Yes. That error is for IE7, not IE8, and produces a different error message. The underlying cause is the same (the script is trying to modify a page before its fully loaded). The suggested fix to to upgrade to IE8. I am running IE8. –  Tom W Mar 21 '12 at 13:14
    
You could also disable javascripting all together. You could also upgrade to IE9 –  Ramhound Apr 11 '12 at 14:29
    
The sites need javascript to run. And no, I couldn't upgrade to IE. –  Tom W Apr 11 '12 at 18:46
add comment

1 Answer

No, there is no setting for this and would require modification of the browser such that it defers loading them just like how defer functions. With a proxy you could rewrite the scripts tag it to include the defer="defer" construct instead, which is as closest as you can get. Privoxy isn't capable of doing this and I'm not sure whether there are others, so you might need to write a simple proxy yourself...

share|improve this answer
    
So how is it the sites used to work until I had to re-install IE8? (I know your comment came after my edit about that - it made me realise I should mention it!) –  Tom W Apr 11 '12 at 18:47
    
@TomW: Oh, that makes it quite different. Perhaps you have a different build of it, is it fully up-to-date? It could also be an unclean re-installation... –  Tom Wijsman Apr 11 '12 at 19:00
    
I downloaded it from Microsoft's website when I installed, so I assume its the most recent build. (It's version 8.0.6001.18702). It is possible the re-install didn't work properly. –  Tom W Apr 12 '12 at 14:51
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.