Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I know for sure that "auto updates" was disabled before the restart, and they are still disabled now. Yet, when I did the restart Windows showed me the percent ticker during shutdown, during restart, and I can actually see names of newly installed updates with today's date in Control Panel -> Programs and Features -> Updates.

Is this a known issue? Does Windows just brazenly ignore the prohibition of updates when it feels like it?

Can anybody suggest firewall level solutions to this, like prohibiting Windows or some parts of Windows from communicating with the Internet?

ETA: OK, some Internet research turns up similar claims, e.g. see here

share|improve this question
1  
Other than an IT setting where updates need compatibility testing, usually the only people that turn off automatic updates are the ones that are afraid of a Windows Genuine Advantage update. –  Dustin G. Mar 21 '12 at 4:01
3  
@DustinG. I turn it off so it can't automatically restart my computer... closing every program I have open... have you ever tried to recover 10 open programs, at least 4 of which don't auto-save (notepad, cmd, etc)? It's not nice. –  Bob Apr 20 '12 at 15:48
1  
Rather than stopping Windows Update - you can stop it from automatically rebooting your system using Group Policy. This will work if you have Windows 7 Professional, Enterprise, or Ultimate. –  Dustin G. Apr 22 '12 at 5:42
1  
@EndangeringSpecies, soandos was asking how long it had been since the previous reboot. That is, maybe you had a pending update that did not finish installing until the subsequent reboot. –  Synetech Apr 22 '12 at 6:02
1  
@Dustin: If you're manually updating before auto-update kicks in, then you're not really using auto-update. And how do you suggest one "saves their work" in the middle of a 12-hour render job or save unsaveable program states or workspace configurations? –  Lèse majesté Apr 22 '12 at 6:44

1 Answer 1

Dustin G mentioned this in a comment but I thought it merited a proper answer.

As has been said in comments, there are some updates the MS determine to be so important that they will be installed regardless, giving you no option to preview them.

What makes this irksome is that it will accompany the install with an auto reboot, which may may interfere with long-running e.g. overnight tasks.

if the windows version is suitable (eg Pro, Enterprise etc...) then you can prevent the auto reboot through Group Policy. (this won't stop the install, just present you with the standard reboot reminder dialog that you get when you manually run updates, rather than one that has a countdown timer to do it anyway)

open the local group policy editor:

Win 7: type gpedit.msc into the search box on the start menu
Vista: start->run-> type gpedit.msc

navigate to the following setting:

Local Computer Policy->Administrative Templates->Windows Components->Windows Update->No Auto-Restart with logged on users for scheduled automatic updates installations

double click it to open it up and select "Enable" to prevent the timeout of the restart dialog.

If you don't have access to gpedit.msc due to your Windows SKU, then create the registry entry directly: (create any keys that don't already exist)

32bit:

HKLM\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU

create a DWORD value called NoAutoRebootWithLoggedOnUsers and set the value to 1

64bit: same as 32bit but use

HKLM\SOFTWARE\Wow6432Node\Policies\Microsoft\Windows\WindowsUpdate\AU 

for the key path

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.