Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My router losses its connection to the internet, somewhat, several times a day. It doesn't lose any connections, but it will not transmit data. For example, instant messengers and games will continue to operate, but file transfers will stop and i am unable to load web pages. After a few minutes, everything starts working again.

The computers are configured with static IPs, there are no IP conflicts and DHCP is turned off on the router. The internet connection is cable and the router is a Belkin F5D7230-4.

The problem seems to have started happening when I configured static IPs. I didn't use it much before that, so there is no way of knowing for sure.

Any advice on how to fix this, or do I need to just get a new router?

share|improve this question
1  
Router make and model? Connection type? ADSL, Cable, Etc. –  Dave M Mar 21 '12 at 14:27
    
The connection is cable and the router is a Belkin F5D7230-4. I will update my question to include that. –  Arthur Mar 21 '12 at 14:34
1  
Have you tried using different DNS servers? –  Ƭᴇcʜιᴇ007 Mar 21 '12 at 15:41
    
The primary DNS server is the router itself, with the secondary being one of my home servers. I'll try with the home server being the primary to see if that makes a difference. I understand how that would affect loading web pages, but would that also affect file transfers? Also, given the fact that there are 2 DNS servers, wouldn't the connection default to the second if the first failed? –  Arthur Mar 21 '12 at 16:02
    
I meant to say the router is the secondary DNS and the server is the primary. –  Arthur Mar 21 '12 at 16:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.