Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm testing the Windows 8 Consumer Preview's To Go functionality and created an installation of Windows 8 on an external HD (instead of a USB stick).

I can attach this drive to my main desktop via an external SATA port and boot from it. Windows 8 boots up and runs just fine. I can see the desktop's existing D: drive, which is a Raid 0 setup running on a secondary SATA bus. I can not see the original C: drive, which is fine.

My problem is when I shut down and boot back up into Windows 7. Windows tells me that my D: drive is corrupted and requires CHKDSK to be run. CHKDSK finds lots of errors (I don't remember which, but it seemed like a healthy variety) and has successfully repaired them. The corruption occurs every time I boot to Win8 and go back to Win7.

My question is why is this corruption happening and is there anything I can do to prevent it?

Thanks,

P.S. Yes I know it's beta software. The corruption does not happen on all PCs...just this one.

share|improve this question
    
Oh, I was already told on ServerFault that it was off-topic and I violated their FAQ. So, far got 3 down votes there. –  SergioL Mar 21 '12 at 14:29
    
Since it has nothing to do with servers, yes, I can see why they wouldn't want it. –  Shinrai Mar 21 '12 at 15:13
    
If its not happening to other computers with a raid setup, perhaps its your actual hardware that is the problem, seems like the most likely reason. –  Ramhound Mar 21 '12 at 15:26
    
The byline for ServerFault is "Q&A for system administrators and desktop support professionals," I guess they had a problem with Win8 being in beta. –  SergioL Mar 21 '12 at 19:02
    
I just would like to comment that I am experiencing this problem with Windows 8 RTM and Windows 2008R2: answers.microsoft.com/en-us/windows/forum/windows_other-files/… –  Luxspes Oct 3 '12 at 0:03
add comment

1 Answer

up vote 2 down vote accepted

I suppose Win 8 upgrades the filesystem to a new format that Win7 can't recognize and is then forced to restore the backup MFT.

I also found a post on Technet which seems to describe that problem, with no solution to this day.

share|improve this answer
    
Thanks. That's the problem I'm having. I'll have to track that thread. –  SergioL Mar 21 '12 at 14:41
    
A solution would be to test Win8 in a VM rather than a full-blown installation (and not plugging your physical disk on it). –  Shadok Mar 21 '12 at 15:19
1  
Yes, if all I wanted to do was test Win8...on the other hand, if I need to test the "To Go" capability, I need to plug the drive into multiple PCs...fortunately, the corruption seems to be fixable by CHKDSK. And there is a response in the link that seems to imply that the FAST BOOT option and eSata drives may have issues. Will test and post the results (and mark this as the answer if it works). –  SergioL Mar 21 '12 at 19:01
    
Just to say: The corruption might be fixable by CHKDSK, but the result in my case, with Windows 8 RTM, was that I lost 200Gbytes of files... so this is no minor issue –  Luxspes Oct 3 '12 at 0:47
1  
Turning off FAST BOOT worked for me. It's tricky to find because it's hidden in the power settings. –  SergioL Oct 5 '12 at 21:11
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.