Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am having a weird issue that I can only explain as a possible "port 21 hijack". For some reason, I cannot connect to any ftp sites. The original one I tried was ftp.maltedmedia.com. Filezilla couldn't connect and then I tried several other, all of which can't connect.

I then opened a command prompt window and tried to telnet ftp.maltedmedia.com 21. The screen cleared and when I hit a key, the connection just broke. So it was getting like an empty response.

I do have a local FTP server running on my machine and I can connect to that just fine. When I type telnet localhost 21 in the command window, the screen clears, my welcome message is displayed and I can issue FTP commands to the server just like normal.

Whatever is going on, it seems to be only affecting FTP. My internet and web browsing work just fine.

I tried disabling my antivirus and disabling my firewall. Some thing. Does anyone have any idea what this could be or how I can trace what program, if any, is blocking this.

This is a Windows 7 machine, by the way, using Filezilla as the ftp client.

share|improve this question

migrated from serverfault.com Mar 21 '12 at 18:36

This question came from our site for system and network administrators.

    
Try firing up CurrPorts to see if anything is using port 21: nirsoft.net/utils/cports.html –  zim2411 Mar 21 '12 at 20:20
    
Sounds like a Firewall issue. Are you using PASV/ACTIVE? –  Ben Lessani - Sonassi Mar 21 '12 at 23:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.