Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to install new RAM in my friends iMac, something I have done several times before. We unplugged the computer before performing the upgrade, used anti static wrist bands, and yes the memory is compatible and inserted correctly.

The stock RAM was Hynix 1gb pc2-5300s-555-12 and the memory we are replacing it with is 2x2gb Centon CMP800SO2048.01. Now I know this model number suggests that the ram is 800MHz and the iMac is only 667MHz but it clearly states on the box that this RAM is PC2-5300 667MHz compatible.

The problem is, that when I install the new RAM I get little response from the computer. I hear the hard drive and disk drive start to initialize, but then they just stop and the screen remains black. I have tried every variation of the new RAM and the old RAM in both slots and even tried the same RAM from my old iMac and I just can't get it to boot. Has anyone ever had a problem like this?

Thank you in advance for any and all input on thus issue!

share|improve this question
Does it boot with its own old RAM ? – harrymc Mar 24 '12 at 10:15
No it does not. – Mick MacCallum Mar 24 '12 at 11:45
up vote 2 down vote accepted

Now I know that this is strange, but it turned out that the guy at compusa gave me the wrong ram. Even though it claimed to be 533, 667, and 800 MHz compatible, I needed RAM that only operated at 667MHz. I got new RAM in today and it booted right up, I don't know why it won't boot with the old RAM any more, perhaps the module was somehow damaged during removal.

Thank you for your help @harrymc.

share|improve this answer
You're welcome. It's rare when 2 problems happen at once, but it did happen to you. – harrymc Mar 25 '12 at 16:45
Yeah, usually makes it more... Interesting to solve. – Mick MacCallum Mar 25 '12 at 17:31

If the computer doesn't boot any more, even with its own old RAM, then the problem isn't with the RAM.

It can be anything and everything, starting with the motherboard-RAM seat, capacitors, power supply etc.

If when you boot the fans don't start, then this is probably the power supply. For anything else, a repairman is indicated. For an oldish computer, 5 years or more, any additional investment may not perhaps be justified.

share|improve this answer

I had the same problem because a seller accidentally sent me PC2 6400 800MHz memory instead of the PC2 5300 667Mhz I ordered.

The behaviour I had (and seems to be common, from reading other forums) is that each new 2 GB board would work individually, but only if it was paired with the old 1 GB chip for a total of 3 GB. Someone suggested the reason this works is that the memory bus runs at the speed of the slowest fitted memory.

share|improve this answer
This is strange and seems to be exact model specific, it seems like some 32 bit Mac models will except 2x2gb and ignore 1gb and other won't boot with more than 3gb. – Mick MacCallum Apr 18 '12 at 16:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .