Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Environment:
I am using Ubuntu 11.10 with wmii 3.9 as GUI and uxterm as terminal with bash as shell. The hardware is a Lenovo ThinkPad W500 with a Swissgerman keyboard layout (thus I need umlauts). I am using ibus for Japansese input.

Symthoms:
When I type keys/chars like ~,^ in terminal nothing happens. If I press ö '(arg: 6)' appears, with ä nothing happens, with ü sometimes a command from the history appears.
It is the same behaviour in all terminals I tested so far (gnome-terminal, xfce4-terminal, xterm). It works as desired in other X applications like chromium-browser, skype or texteditors.

Additional information:

> locale
LANG=de_CH.UTF-8
LANGUAGE=en_US:en
LC_CTYPE=en_US.UTF-8
LC_NUMERIC="de_CH.UTF-8"
LC_TIME="de_CH.UTF-8"
LC_COLLATE=en_US.UTF-8
LC_MONETARY="de_CH.UTF-8"
LC_MESSAGES=en_US.UTF-8
LC_PAPER="de_CH.UTF-8"
LC_NAME="de_CH.UTF-8"
LC_ADDRESS="de_CH.UTF-8"
LC_TELEPHONE="de_CH.UTF-8"
LC_MEASUREMENT="de_CH.UTF-8"
LC_IDENTIFICATION="de_CH.UTF-8"
LC_ALL=

> setxkbmap -print
xkb_keymap {
        xkb_keycodes  { include "evdev+aliases(qwerty)" };
        xkb_types     { include "complete"      };
        xkb_compat    { include "complete"      };
        xkb_symbols   { include "pc+ch+inet(evdev)+terminate(ctrl_alt_bksp)"    };
        xkb_geometry  { include "pc(pc105)"     };
};
share|improve this question
up vote 11 down vote accepted

I was having a similar problem when connecting via ssh to Mac OS X using a terminal emulator. Although I'd set LANG to de_DE.UTF-8 I couldn't type in any characters with umlauts.

The fix I found was to create/edit ~/.inputrc (or edit the following lines in /etc/inputrc):

set input-meta on
set output-meta on
set convert-meta off

Now I can type umlauts. I believe this applies to xterms in general.

share|improve this answer
    
Thank you, this fixes the umlaut problem! But I am still not able to type characters like ~, ^ or ¨. – jonas Apr 15 '12 at 15:40
    
It fixed this for me kind of too (after a new login) but there is still something odd: if I type ö I get an ö, but there seems to be a hidden character too: I can delete wich Backspace two characters although I only typed one ö. Entering LANG=de_DE.UTF-8 in the commandline fises this for that session, but is gone in a new shell – rubo77 Feb 29 at 21:19

Set the right locales with

sudo dpkg-reconfigure locales

There you would select de_DE.UTF-8 as your setting. That solves all problems ;)

Info: Changing the value for set convert-meta off in /etc/inputrc is not completely working:
It fixed this kind of too, but there is still something odd: if I type ö I get an ö, but there seems to be a hidden character in front of the ö: I can delete wich Backspace two characters although I only typed one ö

share|improve this answer
    
Thank you for your answer, sadly I cannot test the outcome of your suggestion, since the system this problem occurred does not exist anymore. Furthermore, I do not understand, why changing the locale from de_CH.UTF-8 to de_DE.UTF-8 should change the situation. – jonas Mar 2 at 7:17
    
Not sure, I had an english layout before. But maybe the ch layout also uses deadkeys for ö? – rubo77 Mar 2 at 9:47
    
Yes, it does, de_CH is the the Swiss-German layout, it is very similar to to German layout. – jonas Mar 2 at 9:54
1  
I think this answer should stay for users that have a similar problem, but don't use the CH layout. I guess the solution is to run dpkg-reconfigure locales again (not the specific layout I used) – rubo77 Mar 2 at 10:07
    
Agreed! I wish, I could test if it solves the problem. – jonas Mar 3 at 7:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.