Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm finding it very difficult to Google this, I don't seem to be able to find anyone with the same issue and I don't know enough about the Windows operating system to troubleshoot. The machine(s) we are seeing the problem on are Windows 7 (professional) both 64bit and 32bit.

The problem is with the command prompt freezing up, seemingly randomly. When it does freeze nothing will bring it back to life (i.e. keypress) and it's nothing to do with Quick Insert mode either. It doesn't seem to be when I run standard commands, such as cd, dir, etc, but when I run different programs from the command line.

The annoying thing is that sometimes the prompt will freeze and at other times it won't, using the same program/command in the prompt. To add to the frustration, one of my colleagues who had the same problem seems to not have experienced it for a few days now (we're pretty heavy on the command line). It's not a VPN/RDP thing as suggested in other questions and forum posts, as I've seen this both locally and remotely.

I thought it was to do with the return code signifying an error or some error state in the program, i.e.:

C:\Users\leonardc>mysql -u lalala
ERROR 1045 (28000): Access denied for user 'lalala'@'localhost' (using password:

but this isn't always the case either. In fact the above command hasn't crashed the shell before.

Elevating the prompt to run as Administrator doesn't seem to have any bearing on the problem either. Disabling my anti-virus doesn't have an effect either.

Update: I tried the same commands in PowerShell, but I still get the same problem, it will freeze at random times (more often than not, as with the command prompt, but not always). It's not the same as command prompt in the fact that one might work while the other doesn't, but then the next time I try run the same command in both it will suddenly be different again.

share|improve this question
Does it happen in PowerShell as well? – Zac B Mar 23 '12 at 14:35
I've never used PowerShell so couldn't say. – Leonard Challis Mar 23 '12 at 14:39
Odd. I think it's worth trying the same commands in PowerShell. PS will run any commands that are legal on the normal command prompt, and if it is replicated there too, it may help narrowing it down. – user3463 Mar 24 '12 at 5:41
I've checked it on PowerShell and indeed it still does hang. Interestingly (or annoyingly) it doesn't do so with any consistency, for instance I might run httpd -t in one and it will work, whereas it won't in the other, for instance. I'll update question with this information. – Leonard Challis Mar 28 '12 at 8:21
up vote 1 down vote accepted

After plenty of testing (and more testing) I finally figured out what the problem was (and why nobody could answer); on our work machines is some monitoring software called Spector Pro. When this was disabled it started working, and confirmed it was this by re-enabling it and disabling it again, where the bug could be be reproduced and vanished respectively.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.