Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Currently whenever I try to search in Google Chrome using the omnibar, if my query starts with 'http' I get moved to searching Amazon.

Example: Suppose I can't remember what a particular HTTP status code is. I begin typing "http 200" into the omnibar. However, as soon as I press space after typing 'http', the omnibar incorrectly 'recognizes' this as Amazon, and sends the rest of the query '200' there.

How can I break the association between the word 'http' and the search service 'Amazon' in Google Chrome?

(There's no combination of keys which will 'cancel' the Amazon search - even cursoring down to Google Search will be cancelled if I then continue typing. The only work-around is to go to the Google homepage, which kind of defeats the point of the omnibar).

share|improve this question
    
I typed "http 200" into Chrome's address bar and pressed enter. It opened google.com/… and the top result was Wikipedia's article "List of HTTP status codes". –  RedGrittyBrick Mar 23 '12 at 9:47
    
Yep, I suspect it is something gone crazy specifically on this machine. Just wondered if there is something specific I can tweak before I try nuking the whole cache/install. –  stusmith Mar 23 '12 at 9:57
add comment

2 Answers

up vote 4 down vote accepted

Source: https://support.google.com/chrome/bin/answer.py?hl=en&answer=95653

  1. Click the wrench icon wrench icon on the browser toolbar.
  2. Select Options (Preferences on Mac and Linux; Settings on a Chromebook).
  3. Click the Basics tab.
  4. Click Manage search engines in the "Search" section.
    • Remove a search engine: Select the search engine from the list and click the x that appears at the end of the row.
    • Add a search engine: Scroll to the bottom of the dialog and fill out the following fields:
      • Add a new search engine: Enter a nickname for the search engine.
      • Keyword: Enter the text shortcut you want to use for the search engine. Use the keyword to do keyword searches.
      • URL: Enter the web address for the search engine.
    • Edit a search engine: Select the search engine from the list and click the field you want to modify.
    • Make a search engine default: Select the search engine you want to use as your default search engine and click the Make default button that appears in the row.

Of particular interest is the keyword. Try editing the Amazon search, and taking a look in there. If you don't need the Amazon search, just deleting it would work too.

share|improve this answer
add comment

If it is a search suggestion , remove it.

When the suggestion loads up, press Shift + Delete, it removes the wrong entry.

share|improve this answer
    
Shift+Delete didn't work, but right-clicking on the suggested search took me to the list of search engines so I was able to delete it there. –  stusmith Mar 23 '12 at 11:59
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.