Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am having an intermittent problem with my network connection dropping out for no apparent reason. When it drops, I still see the lights blinking on the NIC card, but cannot pass packets even to the router. Windows does not report the connection or the cable as disconnected when this problem is occurring. When the issue occurs, I can't ping the gateway, do DNS lookups or pass any packets as far as I can tell. Ping tests all just time out when the problem is going on. The problem will persist until I disconnect and reconnect the CAT-5e wire, or disable and re-enable the NIC. As soon as I do one of those 2 things, connectivity immediately returns (and works for another hour or so).

I am running a legitimate copy of Windows 7 Home Premium 64-bit on an HP Pavilion. All of the latest Windows updates and the latest firmware drivers are installed. My Ethernet connection is a wired Local Area Connection with a static IP address, gateway and DNS. The IP address, gateway and DNS settings are accurate and work for several other computers here.

The Network Interface Card is a Realtek PCIe FE Family Controller (VEN_10EC / DEV_8136 / REV_05). NIC Power Management, Energy Efficient Ethernet, and Link Down Power Saving are all turned off. On the NIC, ARP/Large Send/IPv4,TCP,UDP Checksum/NS Offload, and Flow Control are all on. Receive Buffer Size on the NIC is 64Kb (512 buffers). Receive Side Scaling on. 128 Transmit Buffers. Interrupt Moderation is turned on. Magic Packet features are turned off. Optimal Performance enabled. NIC Speed and Duplex are set to 100mbps Full Duplex wherever possible (automatic was also tried). 802.1X authentication (EAP or PEAP) is disabled. Auto connection logic is disabled.

Connection routes through two switches into a Belkin router; other devices on same networks unaffected. Much of my data is stored on a Network Attached Storage device, with UNC shares mapped to drive letters. Other Windows, Mac and Linux devices connected to the same NAS device have no problems staying connected.

I have tried swapping out the CAT-5e cables for other cables, and even ran them through a cable tester to make sure they're working.

Network fixes I have attempted from the OS level so far include:

  • Switching the dynamic port range to start at 10,000 and run for approximately 54,000 ports
  • Systematically reviewing every running service to make certain that only the essential ones are on
  • Disabling all NIC stacks except Client for Microsoft Networks, IPv4, File and Printer Sharing and Comodo
  • Attempted connections with Comodo turned completely off and its NIC driver disabled
  • Attempted rolling back the RealTek driver to an earlier one from the same family and device line

Using netsh I have tried the following settings:

  • netsh winsock reset catalog
  • netsh int ipv4 reset reset.log
  • netsh int ipv6 reset reset.log
  • netsh int tcp set global rss=enabled
  • netsh int tcp set global chimney=automatic
  • netsh int tcp set global autotuninglevel=disabled
  • netsh int tcp set global congestionprovider=ctcp
  • netsh int tcp set global ecncapability=disabled
  • netsh int tcp set global timestamps=disabled
  • netsh int tcp set global netdma=enabled
  • netsh int tcp set global dca=enabled

I have ruled out any malware, spyware, virus or trojan horse as a possibility after extensive scans with:

  • MalwareBytes Anti-malware 1.60.1.1000 (subsequently updated to latest DB)
  • Kaspersky TDSSKiller
  • Microsoft Antimalware Security Essentials
  • Avira AntiVir
  • GMER
  • RootkitRevealer
  • Sophos SAR 15 SFX
  • PrevX v3.0 CSI Free Edition

Here's the output from an IP Config command:

C:\>ipconfig /all

Windows IP Configuration

   Host Name . . . . . . . . . . . . : User-HP
   Primary Dns Suffix  . . . . . . . :
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Realtek PCIe FE Family Controller
   Physical Address. . . . . . . . . : 3C-D9-FE-ED-FA-CE
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   IPv4 Address. . . . . . . . . . . : 192.168.2.130(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 192.168.2.1
   DNS Servers . . . . . . . . . . . : 91.191.136.152
                                       62.141.58.13
                                       85.214.73.63
   NetBIOS over Tcpip. . . . . . . . : Enabled

What could be the problem and how do I fix this?

share|improve this question
    
Forgive me if I missed you saying you tried this already, but is replacing the RealTek card with a different brand an alternative you're willing to explore? I've encountered some issues with RealTek network and sound cards that have made it become one of my personal blacklisted brands. –  Darth Continent Mar 23 '12 at 13:35
    
I have also seen issues with these; I agree with @Darth Continent that you should try a different controller entirely. –  Shinrai Mar 23 '12 at 14:16
1  
Also, I took the liberty of editing this to be more human readable and removing some of the ridiculously hard to read wall-o-text. If you're reading this for the first time, in the unlikely event that the list of every installed software and/or a HiJack This log would be helpful to you to answer this, go look at the post history - those are in the original revision. –  Shinrai Mar 23 '12 at 14:30
1  
Hmm... well, the edits are greatly appreciated (I had noticed it looked like crap when I copypasta'd it from my Notepad file I was using as a source to populate a few different online forums with the question). However, I really hope someone has a better answer than, "Realtek makes lousy cards. Replace your NIC." –  Crates Mar 23 '12 at 19:54
    
I hope there's a better answer too. I just don't know of one. I will say there's no obvious software mechanism for this, so I'd suspect either a poor driver or a poor controller. The only way to reasonably fix either is to switch NICs. (If possible, you could try running off a non-Windows OS for a bit to see if it still does the same thing, which would rule out software more or less entirely.) –  Shinrai Mar 23 '12 at 20:16
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.