Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to make this command work:

telnet s1.runtime.heroku.com 5000

When I run it, I get the following error:

Trying 107.20.246.116... telnet: Unable to connect to remote host: No route to host

I know I need to set up port forwarding for port 5000, but I can't figure out what settings to use. I am running ubuntu 11.04 on a home wireless network. I have a linksys wrt160nv2 router, and I have the Applications & Gaming tab open. What do I use as the application name? I have tried "heroku", but that didn't seem to work. I have set the external and internal ports to 5000, protocol "both", and "to ip address" 192.168.1.102. Is there a simple fix for this?

share|improve this question
add comment

2 Answers

heroku.com is an external service in the Internet. You don't need to configure your home router to be able to access it.

Port forwarding is used when you want other locations to be able to connect to servers in your home. You don't need to use port-forwarding to connect to any Internet server regardless of the port number.

For diagnosis try

  ping s1.runtime.heroku.com

You should see

C:\>ping s1.runtime.heroku.com

Pinging ec2-107-20-246-116.compute-1.amazonaws.com [107.20.246.116] with 32 bytes of data:

Reply from 107.20.246.116: bytes=32 time=116ms TTL=52
Reply from 107.20.246.116: bytes=32 time=116ms TTL=52
Reply from 107.20.246.116: bytes=32 time=116ms TTL=52
Reply from 107.20.246.116: bytes=32 time=116ms TTL=52

Ping statistics for 107.20.246.116:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 116ms, Maximum = 116ms, Average = 116ms

If ping doesn't succeed, you can check where the problem lies using tracert

C:\>tracert s1.runtime.heroku.com

Tracing route to ec2-107-20-246-116.compute-1.amazonaws.com [107.20.246.116]
over a maximum of 30 hops:

  1    <1 ms    <1 ms    <1 ms  your_local_home_router_name
  2    37 ms    35 ms    36 ms  your_isp_router_name
  3    36 ms    35 ms    35 ms  a_router_in_your_isp_network
  4    36 ms    37 ms    37 ms  a_different_router_in_your_isp_network
  5   120 ms   118 ms   117 ms  some_other_network_company_router
  6   116 ms   115 ms   115 ms  foo
  7   115 ms   115 ms   116 ms  bar
  8   121 ms   118 ms   119 ms  elsewhere
  9   116 ms   117 ms   117 ms  someplace
 10     *        *        *     Request timed out.
 11     *        *        *     Request timed out.
 12     *        *        *     Request timed out.
 13     *        *        *     Request timed out.
 14     *        *        *     Request timed out.
 15   118 ms   115 ms   116 ms  ec2-107-20-246-116.compute-1.amazonaws.com [107.20.246.116]

Trace complete.

The "Request timed out" lines just indicate a router that doesn't respond to route-tracing requests for security reasons. The final line indicates we reached the heroku service (which uses Amazon infrastructure)

share|improve this answer
    
I'm trying to run commands through heroku's command line interface. The telnet command is just a simple command to test whether the proper communication channel is setup correctly. This is following up on communication with heroku support staff about being unable to run the needed commands. –  japhyr Mar 23 '12 at 15:49
    
I can ping successfully. But I believe heroku does need access to my machine. Any suggestions on how to get the actual telnet command to work: telnet s1.runtime.heroku.com 5000? –  japhyr Mar 23 '12 at 15:52
    
@japhyr: I can connect to heroku's "command line interface" by typing that telnet command - I did not need to set up any port-forwarding or reconfigure my router. –  RedGrittyBrick Mar 23 '12 at 15:57
add comment

EDIT: I assumed Heroku ("hero", and some Japanese ending, come on :-) ) was a game that you wanted to run a server for, but the other answer says that is not the case.

Ignore everything below this line (will remove the post later, just wanted to make it clear that I saw the other post).


Click "Single Port Forwarding". Enter

  • Application name: Heroku
  • External port: 5000
  • Internal port: 5000
  • Protocol: Both
  • To IP adress: [your internal IP address] (make sure you have set up the router so that your local machine always gets the same internal IP)
  • Enabled: Check

Click "Save settings", and it should be done.

If not: then something else is in the way for your application:

  • A local software firewall (Sygate, Kerio, ZoneAlarm, etc.),
  • Windows internal firewall (mentioned separately since it is so often a problem. Be triple-sure that it is not in the way. Test disabling it for a short test period if it is active),
  • some overly zealous anti-virus software.

It is not only the router that can block the connection.

share|improve this answer
    
I think the problem might be the "to ip address". How do I find my machine's internal ip address? –  japhyr Mar 23 '12 at 15:46
    
How is this different than the communication needed to get a game server working properly? Isn't it a similar setup as far as port configuration goes? –  japhyr Mar 23 '12 at 15:56
    
@japhyr: Start, run, cmd, ipconfig. –  RedGrittyBrick Mar 23 '12 at 15:59
    
I think I have things set up right on my end. On ubuntu, the command is ifconfig and I have confirmed my machine's ip address as 192.168.1.100. So my settings are application 'heroku', external and internal port 5000, protocol both, to ip address 192.168.1.100, enabled, saved. I still get the same "no route to host" error. Is my next step calling my ISP and asking if they do anything to block this port? –  japhyr Mar 23 '12 at 16:20
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.