Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a rather peculiar home networking issue. For sometime my home network was purring along fine. I could turn on either of my laptops and they would quickly find and connect to my DSL modem (and thence the internet). Several days ago I unplugged my DSL modem for the first time in months. Upon turning it back on and waiting for the boot to finish, the lights on the panel indicated the DSL modem was fully operational, just as before.

But that's not what happened. Not at all.

Now when I turn on my Win7 laptop, the network icon in my system tray shows a small starburst; hovering over it the tooltip states "Not connected; connections are available". Clicking it lists several nearby networks including my own network showing a strong signal. If I click to connect, it attempts a connection but then I get a dialog stating "Windows was unable to connect to MyNet.". Turning off wireless on my laptop and turning it back on yields no difference. Running the network troubleshooter (which includes doing a repair on the network connection) yields no difference. The only remedy is to reboot the DSL modem (i.e. unplug it, wait a few seconds, then plug it back in). As soon as it goes online my laptop finds it and connects properly.

To add one more twist to the story, this happened to me once before, several months ago. After a couple weeks, the situation resolved itself(!). Everything started working properly again, due to nothing I did.

Final note: this problem only affects the wireless connection to the DSL modem. My desktop computer, connected via hardline to the DSL modem, connects fine when I turn it on.

Any thoughts on why this is happening or how to fix it?

2012.03.26 Update

Per Spiff's answer, here is a snapshot (from inSSIDer) of the wifi signals surrounding me: my wifi neighborhood Thinking that an auto-detect setting was not working well, as Spiff suggested, I noted my router (MyNet) was selecting channel 6 and that channel 1 looked a lot less noisy. So I switched to channel 1 the next time the problem occurred. It worked for one instance (getting me a connection), but the next time it failed to connect with the same problem. I then switched to channel 11. Same problem. Then just for grins I switched back to auto and it selected channel 6 and (this time) I connected! So while I have not fixed anything I have one additional datum: the channel may be the issue, but switching channels does not measurably improve the situation in my brief test.

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

It sounds like what you're calling your DSL modem is not just a DSL modem but also a home gateway router and Wi-Fi AP (access point).

My first guess is that your AP is set to automatically pick a channel at boot time, and it's not doing a good job; it's picking a channel that's not clean enough for Wi-Fi to work well. Try manually setting it to a channel and see how it works. If that channel doesn't work, try another one. Your device probably only supports the 2.4GHz band (channels 1-11). Those channels overlap each other quite a bit, but channels 1, 6, and 11 don't overlap each other at all. It's usually best to just pick the channel that functions best out of 1, 6, and 11.

Update 2012-03-26: I'm not sure you've learned anything with your channel changing tests. You already said that rebooting the router made it work for a while. Well, changing the channel may be about the same as a reboot, so saying, "I changed the channel and it worked for a while" is no different from saying "I rebooted and it worked for a while".

As for the inSSIDer plot: Wow, whoever runs network "Belkin 3B38" is being a jerk, probably without realizing it. Not only is it being un-neighborly by using wide 40MHz channels in the crowded 2.4GHz band, but it's also "taking its half out of the middle" by using channels 3 and 7 instead of putting itself at one end of the band or the other. AND it's the strongest network around you, so that's going to be a problem. Come to think of it, the two other un-neighborly 40MHz networks in range (two of the ones in blue) are also using the middle of the band instead of band-edge channels. Oh well. If Belkin 3B38 took channel 1, you might be able to use channel 8 successfully without fighting too much with either Belkin 3B38 or RUGEL.

That said, inSSIDer only shows other visible 802.11 networks, I don't know if it shows hidden networks, and it certainly doesn't show non-802.11 interferers like cordless phones, baby monitors, wireless webcams/security cams, wireless speakers/subwoofers, room-to-room A/V senders, Bluetooth, Wii Remotes, etc. etc. So you still don't know the full picture of interference in your environment, and you never really will unless you use an RF spectrum analyzer (Wi-Spy or better).

I think if I were you, my next steps would be to buy or borrow a high-quality AP and see if it does better than the ISP-provided (read: extremely cheap in all senses of the word) AP. If you buy/borrow a dual-band N-capable AP, and have a 5GHz-capable card in your client, you could try the 5GHz band and see if it's less crowded and works better.

Or, if I could figure out which neighbor owns the Belkin 3B38 network, I might ask them to manually set their channel to 1, and depending on how well that conversation goes, I might ask them to use a 20MHz channel (disable wide channel support in 2.4GHz).

share|improve this answer
    
Thank you for your input! You are correct that it is a modem, gateway and access point. Per your information I did some further poking around--please see my 2012.03.26 addendum in the question. –  Michael Sorens Mar 26 '12 at 22:31
    
@msorens Okay, I updated my Answer too. –  Spiff Mar 26 '12 at 23:50
    
Wow! Thanks for that wealth of feedback; I have gained some good insight from you. I could ask several more follow-up questions for my own edification, but I'll leave it for now and just accept your answer :-). –  Michael Sorens Mar 27 '12 at 1:16
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.