Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My Dell system came with Win7. I installed Ubuntu 10.04 into an LVM encrypted partition with the /boot unecrypted on it's own partition. The PC boots directly to the Ubuntu decrypt screen with no option for choosing a new kernel or the Windows partition. I've attempted update-grub, but the GRUB menu is never presented and the Win7 installation is never detected. I'm guessing I installed GRUB incorrectly...any ideas on what and how I can correct? Thanks!

share|improve this question
    
maybe the delay is too short? try holding esc while booting. if you can go to grub prompt and enter chainloader (hd0, and press tab, do you see your windows partition? If yes, complete the command with the partition number and )+1 and type boot to try to boot from it. If not, maybe you overwrote your Win7 when installing? –  mihi Mar 23 '12 at 18:38
    
I entered the commands and selected (hd0,3) - the partition with win7 on it - entered boot and it says BOOTMGR is missing. I'm guessing I overwrote my win7 bootloader? –  Matt Mar 23 '12 at 21:29
    
depending on how many different Windows OSes you had before, it may not be obvious where your bootloader is sitting. maybe you overwrote the partition of another Windows OS that held the bootloader when installing Ubuntu? –  mihi Mar 24 '12 at 21:29
    
Yes I unknowingly deleted the Win7 boot partition. I had to use GParted to create a new NTFS 150 MB partition just before the Win7 partition. I then set the Win7 partition boot flag (needed for Win7 Recovery Disk). I booted from the Win7 Recovery Disk and it detected my Win7 OS install and reinstalled the missing Win7 boot partition. I might have had to use bootrec /fixboot...I can't recall. It booted fine per your instructions, but still would not show up in GRUB menu. Somehow my 10.04 system did not have GRUB2. I installed it - ran update-grub2 and viola- my Win7 is now selectable from GRUB. –  Matt Mar 26 '12 at 21:36

1 Answer 1

up vote 2 down vote accepted

Recent versions of GRUB have the timeout hidden. You can hold down left-shift during boot to bring the message up or edit your /boot/grub/grub.conf and remove hiddenmeu and set the default to something like 10 seconds timeout=10

For grub2 edit the /etc/default/grub file and make the following changes:

#GRUB_HIDDEN_TIMEOUT=0
GRUB_TIMEOUT=10

NOTE: The # symbol will comment out the GRUB_HIDDEN_TIMEOUT and will enable the menu

After making the changes run sudo update-grub to apply the changes

share|improve this answer
    
shift worked - thank you. I don't have grub.conf but grub.cfg. I commented out hiddenmenu and set timeout to 20 seconds, but still the menu did not appear until I held down the left shift... –  Matt Mar 23 '12 at 21:28
    
On Ubuntu you'll need to edit the /etc/default/grub file and change set GRUB_TIMEOUT=10 and put a # in front of theGRUB_HIDDEN_TIMEOUT line. Then run 'sudo update-grub' to apply these changes. –  Patrick Connelly Mar 26 '12 at 15:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.