Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've read this tutorial: http://howto.gumph.org/content/setup-virtual-users-and-directories-in-vsftpd/
My configuration is as follow:

---vsftpd.conf---
listen=YES
anonymous_enable=NO
local_enable=YES
virtual_use_local_privs=YES
write_enable=YES
connect_from_port_20=YES
pam_service_name=vsftpd
guest_enable=YES
user_sub_token=$USER
local_root=/var/www/sites/$USER
chroot_local_user=YES
hide_ids=YES

---/etc/pam.d/vsftpd---
auth    required pam_pwdfile.so pwdfile /etc/vsftpd/passwd
account required pam_permit.so

I created file /etc/vsftpd/passwd and added users using htaccess. I tried to login but it didn't work:

ftp 127.0.0.1
Connected to 127.0.0.1 (127.0.0.1).
220 vsFTPd 2.3.5+ (ext.1) ready...
Name (127.0.0.1:root): user1
331 Please specify the password.
Password:
530 Permission denied.
Login failed.

Everything seems fine accept the permission denied thing. How can I fix this?

share|improve this question

1 Answer 1

Maybe you forgot to give your ftp user read/write permission to /var/www/sites/$user ?

Try following this guide for setting up the server: http://www.noob2geek.com/linux/setup-vsftpd-debian-ubuntu/

I have used it a couple of months ago with good results.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.