Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I tried shutting my desktop PC (with Windows7) down but after several attempts (like 4 or 5) at Start --> Shut Down, the GUI was still there and it was not shutting down. I didn't think there were any programs running when I pressed Shut Down, so I went into the taskbar (Ctrl + Alt + Del) to check out the processes. Once I did that, a screen appeared with a message stating that there are "background programs" still running and it gave me an option to "Force Shut Down" which I pressed and it shut down normally. Does anyone know why this would happen?

share|improve this question
1  
There are so many possible things that could be running in the background that it would be impossible to guess. Things like anti-viruses, applications that have open files, etc. If this is a common problem, then I'd investigate further, but it seems like it's a one-off for you. –  user3463 Mar 24 '12 at 5:28
add comment

3 Answers

I think your system will be on net and some times some programs have automatically updated through net. If program update is in working then its take more time to shut down the system. There may another reason that some files for shutdown process may be corrupted. In this case you can repair your system by using OS bootable CD or DVD.

share|improve this answer
add comment

You can disable : “clear page file on shutdown” option.

Cleaning the page-file on every shutdown means overwriting the data by zeros, and it takes time.

To clear/not clear page file you can apply this reg tweak. Back up registry before trying this. Start > Run > Regedit

GotoHKEY_LOCAL_MACHINE\SYSTEM\ CurrentControlSet\ Control\ Session Manager\ Memory Management

Modify (if not present, right click in open space and create) the Value Data Type/s and Value Name/s :

Data Type: REG_DWORD [Dword Value]

Value Name: ClearPageFileAtShutdown

Setting for Value Data: [0 = Clear Page File Disabled / 1 = Clear Page File Enabled]

Also open regedit and goto.

HKEY_LOCAL_MACHINE / SYSTEM / CurrentControlSet / Control.

Select “WaitToKillServiceTimeout”

Change the value from 20,000 to some thing like 5000 and shutdown will be a lot faster.

share|improve this answer
add comment

Ultimate Windows Tweaker has an option to "Delete pagefile at shutdown" in its Additional Tweaks section. Not sure whether it simply deletes or actually overwrites as described above.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.