Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The Compatibility Mode feature is greyed out under virtual PCs...

One can directly run a program under Windows 95 mode in Windows 7 Ultimate, but this doesn't work for a lot of Windows 95 programs that do work on WinXP.

enter image description here

share|improve this question
    
Hmm, interesting. Can you post a screenshot of the VM? –  Synetech Mar 24 '12 at 20:18
    
Okay I'll do that in a few minutes –  InquilineKea Mar 24 '12 at 22:11
    
It's not greyed out because of Virtual PC. It is greyed out because the program is being accessed over the network, as your own screenshot says. (XP Mode uses a special network provider for accessing the host's files.) –  grawity Mar 25 '12 at 15:13

2 Answers 2

up vote 2 down vote accepted

I don’t have Windows 7 or XP Mode on hand at the moment, so I can’t give explicit instructions, but I can advise you on a few tests to perform and steps to take.

First, try creating a shortcut to the setup.exe file on the desktop of the virtual machine, bring up the Properties dialog and see if the compatibility tab is enabled. If so, then set it and run the installer from the shortcut.

If it is not, test if compatibility-mode works for local files. That is, simply copy \\tsclient\C\Math Invaders Install\setup.exe to the desktop, then bring up the Properties dialog and check if the Compatibility tab is enabled.

If not, then we’ll need to think up some other tests or try to find out if (for some reason) compatibility is not supported in XP mode.

If it is enabled, then the problem is indeed that compatibility is not supported for remote files. In that case, you will have to try to trick/force Windows into doing it:

  1. Set the compatibility-mode as desired for the local setup.exe (the one you copied to the desktop)
  2. Open the registry editor (regedit.exe) and navigate to HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers
  3. Select the Edit menu and then New->String
  4. Replace New Value #1 with \\tsclient\C\Math Invaders Install\setup.exe
  5. Copy the contents of the local setup.exe entry to the new one (depending on which options you selected, it may only be WIN95)
  6. Close the registry editor and bring up the Properties dialog for the remote copy of setup.exe and see if it has the right settings (regardless of if it is grayed or not)

If it is, try running the setup program. Hopefully it will work (an unpleasant manual work-around, but at least the hack works).

If it doesn’t work, then your best bet will be to simply copy the whole \\tsclient\C\Math Invaders folder to the VM (e.g., the desktop), install from there, then delete the installation files from the VM (don’t forget to set the compatibility-mode for the installed Math Invaders executable if necessary).

share|improve this answer
    
+1, a much more complete answer than mine. –  ta.speot.is Mar 25 '12 at 4:02
    
Wow - that definitely worked. Thanks very much! (though now there's the issue that Windows XP mode doesn't support Direct X :p) –  InquilineKea Mar 25 '12 at 7:13
    
Yes, unfortunately that is a much more involved issue. For that, your best bet is to use full, supported VM software like VirtualBox. Oh, and which part worked? –  Synetech Mar 25 '12 at 18:29

Just tried this out in XP mode on Win7 x64. When I tick the box above the greyed out item, I can select the type of compatibility just fine. So, the greying out of the checkbox shouldn't be happening. You could try editing the registry directly to enable compatibility mode, by following these instructions (inside the XP mode VM), or it may be worth uninstalling and reinstalling XP mode from "Programs and Settings". (This will lose any customisation you've already made to your XP mode VM though.)

Also, compatibility mode is greyed out for 64 bit programs because there is no backward compatibility for these. This is unlikely to be your problem though.

enter image description here

share|improve this answer
    
The problem is that this box is uncheckable (i.e. it's greyed out). –  Renan Mar 25 '12 at 1:00
3  
-1 for not even looking at OP's picture. answered 24 mins ago vs. edited 2 hours ago, so it's not like it wasn't there for looking at. –  ta.speot.is Mar 25 '12 at 1:02
    
Nice assumptions you have there. The picture is small and I have poor eyesight. I thought it looked the same as on my screen. –  Christi Mar 25 '12 at 10:37
    
Have altered the answer to contain some hopefully helpful suggestions. –  Christi Mar 25 '12 at 10:53
    
@Christi CTRL + Mouse Wheel Up: the picture is high resolution, just resized. –  ta.speot.is Mar 26 '12 at 2:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.